Return to Level1Techs.com

Manjaro journal full of core dumps

sys info
pcpartpicker list
[part of the sys logs as it wouldn’t fit in a gist]
(https://gist.github.com/zany130/6b77d0db6db9f9a8d755e439c7fdd71a)

3-26-2020_frezze.txt (2.1 MB)
Hello, I am having issues with my computer freezing. It is very inconsistent, it never happens when gaming. In fact, the only reason I’m posting this is because of my logs. According to the logs, all hell is breaking loose. Apps are crashing (Even though I don’t notice them, except Steam, steam is very unstable on my system but just the client) I have done memory tests and prime95 stress-tests and even some GPU tests and I can’t get the system to crash or give errors that way. The only hardware issue I can think of it possible having is I used to have a smaller PSU on this system for about 2 years (500 watts) and at the end of last year I started noticing some power issue where the computer wouldn’t turn on or some of the fans would fail to spin and I had to open it and give it a push. So I upgraded to the PSU I have now in pcpartpicker (750w) and no more issues but I wondering if the lower wattage PSU might have damaged something.

edit: still happens even after a clean install of the Nvidia drivers(stable branch) and using Manjaro’s kernel

discord and vivaldi core dumps contains both errors with NVIDIA-libs. I guess the stability issues with steam are also connected, because steam is basically chromium (as vivaldi).
So my guess is something is wrong with your GTX1080, lets hope it is just the driver. (clean install)
Otherwise try another gpu, after first failed, alongside another clean install of the NVIDIA driver.

also try other driver versions

I have tried several different Nvidia drivers. I haven’t tried a Clean install so I can try that but the werid thing is I’m not getting crashes in my games which is where I would think most issue arise from

just tried a clean install and still . so does this mean my GPU is failling? I don’t have it OC as its factory OC. But if my GPU is failing why do my games still run fine? its only applications that are having issues and I don’t even notice them crashing except steam

can’t say this for sure. The causing libs are libnvidia-eglcore and libnvidia-glcore. Searching for it gave this result:
https://forums.developer.nvidia.com/t/segfaults-in-chrome-libnvidia-glcore-so-on-gtx-1080-with-384-98-390-48/59965
It fits your system quite well. The original author, of this post, said it did not manifest in crashes under full load and for him it was memory overclocked.
So I suggest testing the jedec-speed of your memory modules.

You could also try the script provided in the first respond.

On the other hand, if this also don’t work. Try temporally the nouveau-driver stack.

1 Like

thats for the old ryzen though i belive it dons’t apply to my system i have a 2700x

and nouveau dosn’t work on my system i tried it when i was doing a clean install of my drivers

aperenty this is a known issue take a look at https://bugs.archlinux.org/task/65643

it looks like glibc is breaking discord and other apps

sorry to hear that, your link is broken for me, so I can’t help you further on this front. It is version depended?
Did you try downclocking your memory, maybe create a profile with your current settings, downclock memory, test and if it really doesn’t help, load the saved profile.

Fixed the link and I was running my memory in xmp mode but I I took that out and clocked it at 2933 as I heard that supposedly Ryzen dosn’t support memory speeds higher than 2933. Maybe I should try lowering it further

So it is version depended. Have you tried downgrading, like it is discussed in the comments of your link:

Comment by loqs (loqs) - Friday, 20 March 2020, 20:02 GMT

If you downgrade glibc to 2.30-3 can you still reproduce the issue?

Comment by Magnus Boman (katt) - Friday, 20 March 2020, 21:07 GMT

Holy shit, yes! downgrading glibc to 2.30-3 fixes it!

Comment by grayarcher (grayarcher) - Saturday, 21 March 2020, 15:44 GMT

The root cause here is a change in glibc, as noted by the 2.31 release notes:

System call wrappers for time system calls now use the new time64
system calls when available. On 32-bit targets, these wrappers
attempt to call the new system calls first and fall back to the
older 32-bit time system calls if they are not present. This may
cause issues in environments that cannot handle unsupported system
calls gracefully by returning -ENOSYS. Seccomp sandboxes are
affected by this issue.

Since it’s the individual applications like Discord, or any other electron/CEF based/like app that apply the seccomp filter, they will have to adjust their filters. Until that happens, the options are:

So I guess my tip for lowering ram-speed is not necessary anymore.

i don’t know how i can downgrade my glibc version. and the issues are not really such a big deal. its just see all those core dumps made me worry something was wrong with my system and it didn’t help that very rarely my system would lock up

1 Like

https://wiki.manjaro.org/index.php?title=Downgrading_packages

1 Like

downgrading glibc fixes all the coredumps i was having i still get very occasional hangs (where the whole screen turns black in fact it seems like the whole computer shutdowns as my rgb keyboard also turns off and I can’t REISUB) im not going to close this yet in case someone has an idea bout that