Managing EFI partition

Hi, today I’ve got what looks like a simple issue but that I can’t figure out for the love of my life how to solve. Months ago I tried Kubuntu 18.10 in dual boot with Windows. I didn’t like it so I deleted the partition, no harm there. But I’ve noticed that the two entries to boot Ubuntu keeps popping up in my boot manager. After some digging around this is what I’ve found:


How do I delete the “ubuntu” and “Boot” partition? Do I need to delete both? Thanks a lot for the help!

1 Like

Yes simply removing the ubuntu entry should work but whatever you do don’t delete the other Boot entry because it is still needed by Windows and doing it this way isn’t recommended.

if you want a more safe approach than just deleting files and still have access to Linux (even live usb) you can remove the boot entries using efibootmgr by running it to find the ids for the entry:

[email protected] ~/.local/git/0cd.xyz(master) » efibootmgr
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0001,0004,0014,0003
Boot0000* Fedora
Boot0001* Windows Boot Manager
Boot0003* UEFI: Built-in EFI Shell
Boot0004* Linux Boot Manager
Boot0014* Fedora

and to delete it you can run efibootmgr -Bb followed by the id like this:

efibootmgr -Bb 0000

In my case this will remove the boot entry for Fedora.

2 Likes

Thanks a lot for this little guide. I used “visual BCD” on Windows (which is the same as efibootmgr I think) but those entries keep popping up when I delete them after a reboot. So I attributed it to the existence of those folders.

“Boot” and “ubuntu” have the same date of creation, that why I was wondering about if I had to delete them both.

Unfortunately I had the really bad idea to not disable secure boot when I installed Linux so it made things really hard.

I used efibootmgr and looks like the Ubuntu entry is gone for good. But I still have a question: why the ubuntu folder is still presenti in my EFI partition? Should I be “worried” about it and try to delete is somehow?

All efibootmgr does is remove the entries from your UEFI BIOS and doesn’t touch the drive, it should be safe to remove it now if you want.

1 Like

That’s what I wanted to do from the beginning. I tried mounting the partition through live Kubuntu but the usual “mount” command doesen’t seem to work (I can’t see the drive in Dolphin) and trying to mount it through the partition manager integrated into the system doesen’t work either. I really don’t know how to do that.

What is the output of lsblk? you should just be able to mount it with sudo mount /dev/sda1 /mnt with /dev/sda1 being your EFI partition.

1 Like

Looks like bootmgr didn’t get rid of the issue. After turning on my PC today the entry came back. I flashed my USB drive with PopOS and I managed to mount the EFI partition correctly. What should I do now? Also the positions of all the entries in efibootmgr are different than yesterday. Yesterday Ubuntu was 3001 iirc and today is 0001. Is that normal? Should I delete first the entry through efibootmgr and then delete the ubuntu folder from the EFI partition?

yes, delete the ubuntu folder and remove the entries using efibootmgr, It looks like your UEFI BIOS just found those on the EFI partition and just added it back again.

1 Like

So it doesen’t matter that the entries are numbered differently or the order in which I do those things, right?

Nope that’s just an I’d it assigns to identify them

1 Like

Alright, I’ll do it. Thanks a lot for the help and patience answering my dumb questions. I really appreciated it.

1 Like