macOS Kitty Terminal

I have been trying to use Kitty for my Mac’s terminal, but I have still some issues. In the normal terminal, when I press option + (left|right) arrow I jump over words in the corresponding direction.

However, I haven’t been able to get this to work properly. I have tried the following settings in my configuration file:

bindkey "\e[1;3D" backward-word # ⌥←
bindkey "\e[1;3C" forward-word # ⌥→

map alt+left send_text all \x1b\x62
map alt+right send_text all \x1b\x66

I have also played around with macos_option_as_alt but it didn’t change anything. Do you have any suggestions? Currently it looks like this when I press option + left arrow + space + | + space + option + right arrow:
[[email protected] ~] ;3D | ;3C

Edit: Ok this was a fast one, the following did the trick:

macos_option_as_alt             yes

# Custom Keybindings
map alt+left send_text all \x1b\x62
map alt+right send_text all \x1b\x66

I’m leaving this here so that other’s can find this as well.

1 Like