macOS Cursor Glitch

Hey guys!

I recently built a Hackintosh around a Ryzen 3700 X and a 5700 XT Red Devil.
It has been working like a charm, except for one “little” thing, which is bugging me more and more. When the cursor is moving over an area, where it has to change the image, it lags or “stumbles” for a very short period. It is barely noticeable and only slightly annoying, but the cursor is really slowed down.
I did the DuckDuckGo and the Google, to find, that many had this problem, even owners of real Macs and that it nowadays is primarily encountered with Navi GPUs. But there does not seem to be a fix.

This really started to annoy me, when I tried to play my guitar through a low latency audio plugin, where the cursor glitch distorted and blipped the sound of the plugin, when moving the mouse.

Does anybody have an idea as to why this is happening or how I can fix it?


What version of macOS are you running? What mobo do you have? Is the 5700XT the only card in the system, even if you’re not using it for macOS? Try making sure the HDMI port on your mobo is disabled in BIOS, even though your CPU has no iGPU, the port can still be enabled for audio passthrough, and could cause problems for macOS. From what I can tell on other hackint0shing forums, the issue seems to stem from unsupported video hardware being present in the system. If you’re booting with OpenCore, you can use ACPI patching to disable any unused and unsupported hardware in your system.

1 Like

I’m sorry, I forgot to post, that I found a solution.
I disabled “Above 4G decoding” in my mainboard settings and set the appropriate boot flag in OpenCore and the problems disappeared.

If you are still interested in my specs:
I’m running macOS 10.15.7 and OC 0.5.7. The mobo is an ASRock X570 Steel Legend and the AMD is the only GPU.



Good to know! I’m looking to upgrade soon-ish and probably going with the new Radeon, since nVidia doesn’t seem to want to play ball with Apple any time soon (and I can’t stay on 10.13 forever). My only hold-up with going all AMD (which I really want to) is AirPlay Mirroring. It seems to rely on Intel iGPU to work. I’d feel silly building a blue & red system…

Sounds promising!
Are the new AMD cards supported by macOS?
I think I’ve tried to mirror my screen via AirPlay to my AppleTV and if I remember correctly, it worked flawlessly. I can try again tomorrow, if you want, just to be sure.

I assume that Navi 21 will be supported natively in macOS. They currently offer Pros with R580 & W5700X, with support for their consumer counterparts, since they do once again build a computer with regular old expansion ports that plebs can shove whatver they want (as long as it’s red, not green) into. It was nice that the later model original Pros never fell completely out of support during the trashcan fire, before they built the new one. It forced Apple to still have some expansion card support in macOS. I imagine once a mobile Navi 21 part comes out, it will make it into iMacs before they migrate back to RISC based CPUs. I’m still holding out a little hope that “Pro” variant computers will remain x86 and vanilla models will be A-whatever based.
And on the AirPlay front, I usually have the iGPU in my CPU disabled in BIOS for thermals and because I hardly do Premiere rendering or anything that can really leverage it alongside my descrete graphics. I went to try to AirPlay Mirror and the icon on the menubar kept disappearing immediately every time I enabled it in settings. I had to enable “iGPU Secondary Display” in the BIOS and boot Clover with the “igpu_enabler” param (nVidia Web Driver disables iGPU kexts) to get it to work.

Yes, some Navi21 specs had already been extracted from macOS firmware so I am quite positive that proper Macs will also be refreshed soon-ish with RDNA2 GPUs

That would be really awesome. My RX5700XT works really well with macOS.

It would be cool for us Hackintoshers to still have support for x86 based systems. But I am really curious about the new ARM-based Macs and what it will do with the PC industry in general. Maybe some other manufacturers start developing ARM-based systems. We will see.

Hello @MrBene93 I am having the same problem on my Hackintosh, and I was hoping you can maybe get me in the right direction.

I setup my hack with Clover vanilla and the 5700 GPU. Everything is working great except for the minor frame skip / glitch that is happening with the cursor when it switches from pointer, to hand, or pointer to resize.

In your solution post I can see that you gave an explanation but I was wondering if you could go into a bit more detail?

  • What boot arguments did u use?
  • What monitor do you have?
  • Do you use HDMI cable or Displayport cable.
  • Any other things or combination that seemed to fix this problem for you?

In your solution it says that you are running OC, so I tried to setup my hack with OC but the same problem persists. I have tried with a brand new Samsung 4K monitor, but this only made the glitch less noticeable because the cursor is smaller.

I have also tried to change the hoty and hotx in the cursor folder as mentioned on other forums, but this did not fix the problem satisfactory.

It’s a trivial problem, but like you it annoys the heck out of me :slight_smile:

Any help or info would be much appreciated.

Hey @Siege374!
I’m glad, that your Hackintosh is running smoothly, except for the cursor issue.

In terms of boot arguments: I basically use the boot-args, which the OpenCore Install Guide on Dortania suggested.

-v debug=0x100 keepsyms=1 npci=0x2000 alcid=1 agdpmod=pikera

The last thing I did to solve the problem for me was to disable “Above4GDecoding” in the UEFI and add the npci=0x2000 to the boot-args.

I am using two Dell U2515H displays both connected via their own DisplayPort to MiniDisplayPort cable.
I did try to solve the problem by using HDMI, because I was having problems with DP MST earlier (hence the two separate cables), but it did not help.

Afar from that I don’t see anything else, that is connected to this problem. Maybe the fix just worked for my hardware combination.

What hardware are you using?

In my case the problem was a lot more annoying. I use CoreAudio Plugins for playing guitar into Logic Pro X (mostly the ones from NeuralDSP) and for that I have to use a very low buffer, so that the latency is as small as possible. The glitching cursor actually distortet the sound, that my plugins were producing, when I moved it. I don’t know why, but let’s just say, that I was really motivated to get this fixed.

Oh, it’s sad that this happened to you, my cursor often slows down and freezes too, and I don’t know what to do. Therefore, I understand you. Don’t worry, I’m sure this can be fixed somehow.