MacBook won't charge through ThunderBolt 3 Thinkpad dock

Hi there.

I have a MacBook Pro that’s connected to a ThinkPad Thunderbolt 3 Dock Gen 2 dock.
Everything aside from charging seems to be working fine, in the topbar I can see the charging icon when connected, but the % goes down.

The dock supports 230W, but it’s currently powered by a 135W power adapter.

The dock works as expected if I use my T480s ThinkPad which is supposed to be charge with a 65W power adapter. But the MacBook charges if I use that same adapter with it, or any other 65W power adapter.

Do I need to dump more power in the dock to charge the MacBook? Could this be some compatibility issue?
Would love to hear your thoughts and/or suggestions.

So… you’re expecting your PC hardware to work with an Apple product?

1 Like

Tell us more about your MBP. What model? Year, size? My results have varied greatly with TB across devices on both ends. The details matter. There are some known issues with certain MBPs, for example. Also a model number for the dock might be helpful.

MacBook Pro 13-inch 2017 model:

The dock model number for the dock is: 40AN0135EU

Cool. 135w should be able to power 2 of those laptops. It could come down to the cable. I see that dock has a modular cable, which is good. You might try a different cable. I recall the cable being the issue with most of the Apple-related problems I’ve come across. Like, if you got a USB-C cable mixed up for your Thunderbolt cable (hey, I’ve done it). Or it just doesn’t meet Apple’s ‘handshake’ spec. I’m using a MBP 16" on a CalDigit dock with no problems. But I’ve also power the same laptop using an Anker USB-C cable, a long one at that, plugged into AC adapter Apple included. No issue. Anyway, where my brain takes me in troubleshooting the problem is a handshake issue. So I’d try another cable before tossing out the dock or the laptop. But it might end up being just incompatible, the dock that is. Who’s fault? Dunno. Could be Lenovo or Apple or both. I’ve got a little Lenovo travel dock (no power) and it works great but maybe I’ve been lucky.

With the magnetic charger, there used to be a chip in the charger that told the device how much current it could draw.
Detail in this vide

As for your case, there are some articles talking about “Reseting the SMC”, so you might want to look into that.

I tried the cable that came with the charger but then my monitor didn’t work and I had some trouble with the keyboard after restarting.

I followed the instructions as laid out here:
Unfortunately it doesn’t seem to have worked.

1 Like

try reset your SMC.

I’ve had some dodgy hardware wig out one of my thunderbolt ports one time on my 2020 MacBook Air. It wouldn’t charge on that port, etc. an SMC reset fixed it.

edit: ah, beaten like a red headed stepchild.

Be aware not all USB type C cables are the same. Some are only USB-2 standard (for the purposes of charging) and some do thunderbolt, some do not.

The cable that came with your Mac charger is NOT a thunderbolt cable; it’s a type-c USB / “charge cable” (does up to 100W plus USB 3.x, not sure on video, but definitely not thunderbolt 3.0 at full speed - that needs an active cable for > 0.5m) and does not contain the circuitry to do everything.

Hi there,

I’m in a similar situation, have a MBP A1706 witch should need only 60W to charge but when plugged in, it detects being on sector, but not charging enough if the laptop’s power draw is too high.

I’ve tried using an other power supply from Lenovo, the 230W - 11.5A verion, with no benefits.
Also tried the Apple charging cable and an other Thunderbolt 3 cable with no significant change.

Do someone know if a setup like this is enven possible ? Maybe with the 230W version of the dock the 40AN0230US ? Strange thinking that the dock has a 170W/230W power input…
Have you solved your problem ? If that’s the case, could you share the solution with us ?

Thanks in advance.

has anybody tried if it makes a difference from plugging into usb c port in the front vs in the back?

Hi Everyone, did someone find a solution for this issue? I have the same problem with the Thunderbolt thinkpad docking station gen 2, it is not charging both by Macbook Pro and my Lenovo work computer. I tried resetting the SMC on the Mac, changed cables etc. nothing seems to work. Thanks a lot in advance!

I guess somebody has already found the solution. But I’ve just solved this issue by updating the firmware of this dock! You can get the software for the firmware update on lenovo official support site. It might be necessary to use Win10. But once updated, MacBook Pro will be charged by this dock.

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.