M.2 nvme won't alway show up in bios or boot windows

first of all i would like to thank anyone taking their time to look at my post and hope this is the right place to put it :grin:

I brought a sabrent rocket 1tb m.2 nvme as main boot drive and all worked fine for about a month, now all of a sudden my pc won’t always post dispite green q-led on the motherboard, when it does my m. 2 won’t always show up at all in the bios when i first turn my pc on but if I try to install windows from a USB it shows up on the list of drives.

If I leave my pc on in the bios for 5 minutes or so then restart my pc not touching anything in the bios it starts up just fine. Can turn it off n on all I like and use it as normal,mostly gaming.

Since it was showing up on the available drives to install windows I figured I’d give that ago since I didn’t have much on there. At first it wouldn’t let me because it was saying it has an MBR partition table. On EFI systems, windows can only be installed to GPT disk. I’m not that great with computers so i assumed it was playing up becasue of the partition so changed it to GPT and installed windows. Still no good.
I have a 128GB SSD and a 2TB HDD they always show up in the bios and work just fine no problems.
The only other thing i could think of was maybe my PSU is playing up and takes a few minutes to fully power on when it 1st turns on but since it shows up when installing Windows I really don’t know. I tried messing around with csm and reset my cmos but still no luck put the m.2 drive in the other slot still no good.
Motherboard: Asus strix b450-e gaming
CPU: Ryzen 5 3600x
memory: Corcair Vengeance LPX 2x8GB 3600mhz
OS: Windows 10
BIOS: 3004
Storage: Sabrent rocket 1tb m.2 nvme
Crucial 128gb ssd
WD 2tb HDD
PSU: NZXT 650w Bronze
Last 3 parts are all from OLD build and are about 8 years oldish. Just seen there’s a new bios version but with the issues I’m having with it not always posting I’m a little reluctant to update the bios just yet.
Im at a loss so any help from you wonderful lot would be greatly appreciated.

if your bios are older than version 3004 you might want to look into updating,


  1. Update AM4 combo PI patch B
  2. Fixed a compatibility issue with M.2s when using Ryzen 3000 CPUs.*

I have version 3004, I know the latest one is 3103 but with it not always posting I’m a little apprehensive updating the bios just incase knowing my luck it fucks up somewhere :joy:

This happens to me when my motherboard boots the backup BIOS - Then in displays no NVME drives.

A shutdown - unplug power - replug and boot fixes this.

Sort out why your system isn’t always posting and then you won’t get the problem.

Done that a few times now when taking it back n forth to the kitchen to work on it, didn’t work for me.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.