LSI HBA cards not detecting drives

Hi I now have 2 LSI cards that have been flashed to IT mode, but neither of them detects any drives. I’ve tested with TrueNas and Openmediavault, as I’m a tiny bit more comfortable troubleshooting on linux.

The cards power up just fine and the green heartbeat led is flashing on both (only using one card at a time). I have 4 2TB Sas drives hooked up, but they don’t seem to even spin up. 3 of the drives I’ve used before and they worked back then (1 year ago)

I bought another cable, thinking that was the issue, but that did not help. Both cables have Molex power plugs, so the pin 3 issue should not apply in this case. I’ve check with a multimeter that the drives have power, and both 12v and 5V is fine.

I have tried to reflash the cards with and without the mpt2sas bios, that changed nothing, still no drives detected. Hopefully someone smarter than me can help me out here. The card shows up with lspci command and here is the output of grep mpt command, doesnt tell me a whole lot. Thank you for any help than you may offer, I’m at the end of my rope.

Could you please describe your setup further? Specifically the cables you’re using and the model of card you flashed.

Also, is there any output on system logs when a device is connected to the controller? Even with sata drives? Like, is the system detecting something and not addressing?

1 Like

try booting the GPARTED live distro, see if it can see any drives across the cards.

did you do like BLKID or how did you look for drives?

Sadly I dont have any sata to sas cables, so I’m unable to test that. But when entering the bios on the card there were no devices detected.

[heavy edits] does the card connect to a sas backplane?

(You can plug sata drives into a sas hot-swap / backplane)

(just not the other way around. On the offchance you did not know that. didn’t mean to insult your intelligence / experience)

But a normal sas drive will do for detecting devices. was just a different drive, in case one had become uncommunicative.

Yes, I’ve tested on a AMD FX based system and a Ryzen based system. Asrock x470 taichi for am4 and asus 890fx crossair extreme for am3+. Fx8350 cpu and R5 1600. Corsair RM1000i psu, also tested a corsair hx650 psu. Been switching between these gpus: r9 290, hd 6870, gtx 1070.

Here are links for the two cards I’m using. LSI 9207-8i LSI SAS9220-8i

The second one was the card I used last year bought the other one when I thought the card was the issue.

These are the cables Mini-SAS SFF-8087 to 4 X SAS SFF-8482

These I bought when I thought the cables was the culprit Delock

I’ll test it tomorrow, gotta get some sleep now. I used lsblk, also the web gui and in the lsi bios. No drives show up.

1 Like

No backplane, all the parts are in a fractal define xl chassis. No worries, im not the most experienced when it comes to this stuff, still learning. I tried only using one drive at a time, but no drives show up no matter what I try. The drives doesnt even seem to be spinning up, no vibration or sounds. Tried port 0 and 1 on both cards, but with same results.

Oh, it is your psu causing the issue. Plug the drive in to power via a molex to sata adapter. Test first then i will explain the issue.

The cables I’m using for the drives are using molex connectors. Are you suggesting I use sata to molex adapter? Molex to sata wont work as the cables I’m using do not have a sata power connector. I can try yet another psu, the problem is present with a corsair rm1000i and an old corsair HX 650. I have a couple other psus aswell that I can try.

i was thinking you had the cable with the sata power adapter on it but after looking through your links, you do have the molex ones.

you should plug in some SATA drives and see if those are recognized, the smaller in drive size the better for this. like an old 500gb sata drive or whatever you have.

Do you have any way to test your drives? With like an old retired server with a SAS backplane? The fact they don’t even spin up suggests either they all went bad, still a cable issue, or possibly they’re not being sent the signal to spin up because the card is disabled or maybe waiting for something.

What firmware did you use to flash the cards? Do you boot legacy or UEFI? During the post, do you see the LSI card’s BIOS message?

Yeah, I’ll se about getting a sas to sata cable and see if a sata drive shows up.

sadly I don’t. I suppose it is possible, there doesnt seem to be anything wrong with the cards, so unless the brand new cable is bad, which I doubt, drives could be it. The LSI SAS9220-8i card was flashed with 9211it firmware, this was the card I used last year with the same drives. At that point everything worked. The SAS2308 card was flashed with 9207it firmware, I have not used this card before, but it appears to be working.

I have reflashed both cards using both Freedos and EFI methods, didnt seem to matter much, also tried flashing it with and without the mpt2sas bios. When entering the cards bios it says no devices connectoed.

Ordered a sas to sata cable to see if it will detect one of my sata drives. Gonna take a while before it gets here though.

1 Like

Fwiw, sata drives will plug into sas connectors, Just not the other way around….

The only reason I mentioned it, is there is more chance you might have a sata drive to test.

I wouldn’t say it is worth ordering an additional breakout cable just for the test

1 Like

Well dont I feel like a dummy! Just tried a old 500gb sata drive and it spun up and showed up when using lsblk. I guess I have 4 dead sas drives then. That sucks, but thankfull for all the help in diagnosing the issue. You’re all legends!

1 Like

Well, at least one connector works! :slight_smile: I would try the sas drives in that one, just in case?

Also, did you check the model number, in case the drives are formatted in a way the controller might see them, but not pass them to the OS? That’s why we were hoping at least an error might show up.

I don’t think it can hurt to try taping over the 3v pin, but I haven’t heard of that in a sas drive before.

2 Likes