Return to Level1Techs.com

Looking Glass - Triage

helpdesk
lookingglass

#1281

3440x1440 in a 3440x1411 window

Correct, anything that is not exactly 1:1 will cause texture mipmapping/scaling, which is why you’re seeing a drop in sharpness, even that one pixel difference is enough.


#1282

Strange then since the resolutions match.


#1283

How is that the same?


#1284

I have set a custom resolution of 3440x1411 to match the client window size. I don’t run 3440x1440 unless I switch to using the monitor for the guest.


#1285

Newb-ish question. I can’t for the life of me figure out how to install the ivshmem drivers on Windows. I’ve downloaded the zip file provided on that GitHub thread, but what do I do with it?

Edit: Download devcon and run the command
devcon.exe install ivshmem.inf "PCI\VEN_1AF4&DEV_1110&SUBSYS_11001AF4&REV_01"
The inf file has this in the comments at the top, but be sure to include the quotation marks because otherwise the windows cli parses it weird.


#1286

Looking Glass captures the monitor resolution. Not the client resolution like OBS’ Game capture does. Looking Glass captures the entire monitor all at once, not directly hooking into the game.


#1287

Right, which is why I’m running 3440x1411 both as the resolution of the guest as well as the client so they match.


#1288

No, you don’t get it. Looking Glass is a layer above the window manager. It acts more like a Display Capture in OBS compared to a Game Capture.

If the window is 3440x1411, Looking Glass captures the entire monitor anyways at 3440x1440, including your taskbar.

Unless you were somehow able to magically use a crop function in Looking Glass I’m not aware of, I don’t see the raw buffers ending up at that resolution.

Looking Glass in it’s current state likes 1:1 pixel structure borderless fullscreen, with both monitors the same resolution, as the best presentation. But there is no ROI selection for the host with custom resolutions, nor cropping in the client.


#1289

Right, but again, I’m not running 3440x1440, I’m running 3440x1411 in this state.

Screenshot%20from%202018-11-18%2011-49-47

If I run with -F flag instead of -w 3440 -b 1411 a full screen window of 3440x1440 is presented with black bars at the top and bottom because the image inside the window is 3440x1411. If I run without -F and without -w 3440 -b 1411 and just rely on -a to auto resize a window of 3440x1411 appears. This is true for both opengl and egl.

Having said that, does it rely on the active signal resolution or the desktop resolution? It seems to me like it’s using desktop resolution, OBS also says 3440x1411 for display capture.

Screenshot%20from%202018-11-18%2012-03-42

I did some tests at 3440x1410 because I was curious if 1411 being an odd number was throwing it off and it looks like with that resolution both opengl and egl look the same with no blurry text, so it did play a factor. I can see the a little line between the window and my top bar since it doesn’t fit perfectly anymore but not enough to be jarring.

Overall for my setup the opengl performance is still noticeably smoother and uses less CPU, but I can see a potential tradeoff by using radeontop to view the GPU usage that opengl uses more GPU than egl does. It may run smoother in this test specific to WoW as it is very CPU reliant with its old engine; I would need to check with a couple other games what seems to run better.


#1290

It uses Active signal resolution. Not Desktop resolution. Windows 10 is adding to the confusion here. Windows 10 doesn’t count the taskbar in it’s Desktop resolution.

Effing Windows 10. (GET BILL GATES IN HERE)


#1291

I seem to recall something about that too. Really odd choice. In any case I’ll be sticking with opengl for now, time will tell if I should switch. :slight_smile:


#1292

It could be a driver level issue too. Check if you aren’t running any weird custom resolutions, and let your DISPLAY do the scaling, and not your GPU.


#1293

EGL is OpenGL, it’s just OpenGL ES. It’s still early and incomplete which is why you’re seeing this issue. However the issue for you is still present even with OpenGL, it’s just masked by the mipmapping that’s enabled by default.


#1294

Got it. Thank you for the information!


#1295

Commit ab98c87e7c4797ba5bb049a7deca84d964058bcb

Missing lg-fonts.c in the commit? I don’t see it on github.

CMake Error at CMakeLists.txt:68 (add_executable):
  Cannot find source file:

    lg-fonts.c

#1296

Fixed, sorry about that.


#1297

Hi All. Experiencing low UPS numbers in Battlefield V when future frame rendering is turned on. Currently using looking glass build from source and the egl renderer.
Getting numbers around 30-40 UPS.

However when its turned off the UPS equals the amount of FPS i get in the game.

any idea what may cause this issue?


#1298

Well there is your answer, you are loading your video card up with too much work to both capture and render at the same time.


#1299

First of all, love the project!

I was wondering; I’ve always gotten close to good performance out of LG, but I’ve never had it good enough so that I can just play games (that require precision) though it. My UPS is usually above 50 when playing a game, sometimes even maintaining 60. But for no obvious reason it fluctuates in performance without showing huge dips in the UPS nor FPS.

Currently on the latest git build as the v11 is even worse performance-wise (for me). I’m using the parameters -sladM -K 60 (although letting it be 200 doesn’t change performance all that much), vsync=0 and of course EGL. My CPU usage never hits 100%, nor does my GPU (raw output though a monitor is perfect, the performance seems to be only aesthetics? - as in LG doesn’t perform as well as what it does normally). But I have noticed some minor performance gains/losses when tweaking my VM parameters (only noticable though LG).

So is there an optimal VM configuration specific to LG? Or could it just be my hardware or something? (i7 6700k @4.5, 1070 OC, seperate drives for VM, etc., host is using the iGPU, which I’ve tried OC’ing with no noticable affect) EDIT: resolution is 2560x1080

I know it’s very early days for LG, but it just seems strange. Keep up the great work! :smiley:


#1300

I had similar performance problems in LG on my iGPU (8700k). I bought an 1050 ti to use instead for my host and problems went away. I did however notice when I uninstalled the bumblebee drivers I was using for my iGPU in Manjaro and instead used the Nvidia driver, LG performed much better on the iGPU aswell.