Looking-glass - can't get ultrawide resolution

I’ve been running looking-glass successfully for some time now.
A few days ago I noticed there was an Nvidia driver update. 516.94 to be exact. My running version was something like 505, i forgot which.
I updated the driver fine and everything is working fine, except I can no longer get my ultrawide resolution and 100 Hz refresh rate.

Anyone have any ideas on where to poke around to fix this?

My system:
Manjaro on 5.19.1-3 kernel, KDE on Wayland (yes I know but it works)
CPU: Ryzen 5 5600G
Pass-through GPU: GTX 1080 Ti
Windows VM with Windows 11 running on it

the 1080 Ti is passed through to the VM, the ultrawide is connected to the iGPU on the Ryzen CPU through displayport, there’s an HDMI dummy plugin on the nvidia card.

I used to get full 3440x1440 resolutioın ant 100 Hz with this setup before the driver update.
Any ideas?

is the dummy plug [email protected] capable?

if not maybe try this:

otherwise maybe some of the experts here can help (:
( i am a completely new n00b who only read up on how to set things up :smiley: )

If you were using custom resolutions prior you will find that if you stopped hiding the KVM leaf (the old workaround for nvidia code43) you will have lost your custom resolution options. While NVidia now allow the GPU to function, they still cripple some functionality such as this.

To restore it, hide the leaf again and set a new hv_vendor ID as the NVidia drivers remember the old ones and refuse to re-enable the feature if you don’t also change that.

1 Like