Return to Level1Techs.com

Looking-Glass Beta 2 RC 2 - weird mouse behavior

Hello,

my name is Simon, new to this forum :slight_smile:

After updating LG from Beta 1 to Beta 2 RC 2, my mouse is behaving weirdly.
When playing a shooter like CS GO, I can’t turn a full turn anymore, it’s like the mouse pointer is stopping at the edges of the screen.
Any one else experiencing similar weirdness?

Kind Regards
Simon

I found this issue here:

There, two possible reasons for such a problem are discussed:

  • A tablet device is attached to the VM
  • The screen resolution differs from the one in the VM

I can eliminate the first reason, because I don’t have a tablet device attached.
My screen uses a 1440p resolution, the VM is configured for a 720p resolution.
Could this really be the reason for the mouse problems?
Do I have to run my VM @1440p resolution?

Try hitting scroll lock to capture it.

I’m already using scroll lock to capture the mouse.

Not sure if the resolution difference is causing it but you may as well test it as the next step.

I tried to use the same resolution on both guest & host, but I still get the same behavior.

RC2 has some issues with old frames being displayed I am trying to track down still, it might be the cause.

If I find the time, I’ll try to find out at what point in the git history the problem arises.
Like a kind of manual git bisect.
Automating this task is probably not so easy, because of how complicated it would be to detect success/failure.

The cause is already known, a solution is in the works.