Return to Level1Techs.com

Logitech G700 Mouse Issue

So I have a pair of Logitech mice I use, one on my gaming rig and the other on my workstation.

The Workstation machine is the Threadripper machine with the G700 mouse.

The gaming machine is a 3800x with a G700s mouse.

Since I game a lot I first noticed the following issue on the gaming rig first.

Randomly while gaming the mouse will freeze in that I can move the mouse any way I want but no input to the game what so ever.

To fix it I disconnect the micro USB cable and then power off the mouse with the switch on the bottom.

I then reconnect the USB cable and then power on, good to go until it randomly freezes once more.

Thist started happening around 4 ~ 6 months ago.

Bit since it IS happening with both mice on both machines I am wondering if it is a design flaw.

I tried replacing the Ni-MH battery with a new one but it is still happening.

The only thing I have not tried is to remove the battery altogether and see what occurs.

I’m also looking to replace said mice but I really like the feel and the weight of these mice.

Does it only happen with the USB cable plugged in?

I do not know, since I only use the mice as wired and NOT wireless.

Yes I’ve tried the wireless mode but it’s not responsive enough for me and the shape of the mice is what I’m after, the ergo shape and the weight and the fact they are NOT tiny in my hand.

Hm, I also have a g700s and get similar symptoms when I unplug or plug in the mouse. Sounds like the USB connection on the mouse end is flaky for your mice.

How about trying a different USB cable. Ideally one that is really flexible and fairly new.

yep
the same

So I will have to look for a replacement cable then, I would hope they are using the standard USB to micro-USB type cabling ?

Yes. Some cables that have huge casing on the micro B end might not fit, but the port is standard.

The issue could always be with the port instead of the cable, in which case it is either soldering on a new port (if you can find a replacement that fits) or buying a new mouse.

Thanks for the feedback :slight_smile:

sounds like a USB issue with the machine, not a mouse issue.