Return to Level1Techs.com

Locked myself out of Syncthing and PiHole consoles on FreeNAS, but those services are running and working

So I have FreeNAS running and I installed Syncthing plugin and started to configure it to replace what I use dropbox for at the moment. I was watching Tom Lawrence video as guidance but managed to screw it up. :smiley: I try to list first all info needed but please ask if I missed something.

  • OS Version: FreeNAS-11.2-U7
  • I have 4-port LACP to switch, which includes 3 VLANs. .5.xxx, .10.xxx, .15.xxx. All /24. (IMAGE)
  • Syncthing plugin is installed, and configured to run static IP 192.168.5.66 /24. It is up and running. Management was working first but now it doesnt. We’ll return to this later…(IMAGE)
  • I created user “sync” with UID 983 which should give permissions for syncthing to do its thing. (IMAGE)
  • Next I created dataset, and set permissions for user “sync” and group “sync”. (IMAGE)
  • Then added mountpoint for syncthing jail with new empty folder. (IMAGE)

Now I was set up to open management, installed syncthing on my phone, added freenas device and made the connection, set folder on phone where i copied few files for testing purposes and shared it with freenas. Now as I went to management in freenas, I see the folder I shared, but I get prompted that folder inside jail can not be created, there was problem with permissions. For one hour I was going through settings, watching the video again and again and trying to figure out what I did wrong but couldn’t find anything. Next I went to google and found out I could create the folder inside jail in shell so I did. mkdir worked fine, managed to create the folder and as I went to syncthing management I saw that the folder on my phone was synced and it was working as intended.

  • Next I added another user (my main pc) to group “sync”, set SMB share to /mnt/Ironwolf2x4TbMirror/SyncthingData (IMAGE).
  • I am able to connect to this share, but the synced folder inside is empty. (IMAGE)

Now I went back to syncthing management to check why this folder is empty even tho just minutes ago it showed in management that folder is synced. I click management button under plugins > syncthing > … and this is what I get. Any ideas why I’m blocked out of management? Shell for syncthing jail still works. Why did I have to manually create the folder? I have tried restarting the jail but it didn’t help.

Imgur

I found that for some reason my dataset permissions was set to windows, so I changed it to unix but it made no difference on the management problem.

nginx seems to be working and networking side should be fine. Is it possible to check in shell if syncthing services are running? Or would it be easier to just reinstall the plugin to regain control?

Imgur

It seems I have rather broke something in freenas than syncthing, as also pihole admin console running on ubuntu desktop bhyve vm can not be accessed. pihole itself is blocking ads and working as intended.