Local Internet Problem, Some Sort of IP Block?



Ok so on the regular I get 8Mbps, sometimes six, but when I turn my computer on (yesterday and today) it only run at 54Kbps. Yesterday I restarted my PC and it was fine, but thus is my third time restarting and it's still not fixed. I could just keep restarting but i'd like to know where the actually fuckery is going on as it is completely stupid and really makes no sense. My pc goes into a 10/100 8 port switch that then goes into either a 24 port 100/1000 or 8 port 100/1000 and then into a router and then modem and then phone line. I can turn on my laptop and connect to the wireless and get 8Mbps just dandy, and it's connecting to an AP that is going through all the same things as my desktop so that rules out hardware and port problems.


Is it possible for a router or switch or another PC to block my personal dektop's very own subnet iP address? (i.e all connections on 255 are fine except for which ever one my PC is on?)


Any ideas?


sounds like ISP throttling - do you have a data cap?

Well no they're not because I don't think they can throttle just one computer inside a local network. We have 500GBs and have used 300GBs. Renews on the 30th.

So you can get on the internet but it's just slow? Or are you totally unable to connect? Can you access anything on your local network and if so is it the same speed as your internet or are local connections working at the right speed?

If possible try connecting your computer directly to the router to rule out one some problem in the network. Next check your network adapter settings, if you're not using DHCP and you have manually set up your IP address then make sure the settings are right, make sure they are the same (except obviously the IP address) as your laptop which is working. If your gateway or DNS addresses are set up wrong this could be what's causing the problem.

It might also be a driver problem, you could try reinstalling the drivers for your network card. It could also be some software issue on your computer, a firewall or virus scanner maybe. try disabling those and maybe try using a different browser.

In answer to your question, yes it is possible to block your IP address on the firewall in your router, but if someone were doing that you would have no access to the internet at all not just a slower connection. If you want to rule this out then you can test it by changing your IP address to something else and see if that changes anything. If you're using windows are you seeing the little yellow triangle thing on your network icon in the taskbar? If you are then there is something wrong with your connection. If that is the case and you've got a manually configured IP address then change it to auto and see if that fixes it. You might have set it to an address which conflicts with something else on your network.

Yeah, well sometimes it just times out, but mostly it just goes really slow, I did a speed test and it said 1.5Mbps, it seems to be all over the place, sometimes it says I won't have a connection to the internet but it will still load things (not cached things). 

I found out that the AP is on my bedroom switch that then goes to the switch in the modem room, but my PC just goes straight to the switch in the modem room, either way it wouldn't matter. My laptop's local is 1.112 and my desktop's is 1.103 so that's fine i'm pretty sure?

To re-install a driver do I just download it at it'll automatically delete the old one when I install the new one?

I don't haven't set any firewalls and I don't don't use an anti virus.

Hmm yeah, it's almost like i'm being throttled to my computer personally.

I'm not seeing the yellow triangle either (win7) It just looks normal,a nd sometimes in network properties it'll say 'no internet connection' but that isn't always true, unless it's turning ona nd off so quickly that it doesn't have time to change.

I'll try plug it into the router directly and see what happens. As I am posting this my connection has gone back up to 8 but about 10 minutes earlier it was as if it was going through a vpn in china or something ridiculous haha.


Yeah what would happen if I set it manually to something that already had that IP address? I did change it from .1 to .0 back when I was talking to you about the Dlink AP but that was on my alptop and i've changed it back already and changed the Dlink to .1

reset your modem / router.

This sounds like it's an issue with something between your computer and the router. It could be part of the network or software on your computer or even the network card itself. 

Firstly you want to be certain that this is only happening in your desktop and not other devices on your network, once you're sure of that you can rule out connection problems to your ISP and problems with the modem or router.

Then you should connect your desktop directly to the router to rule out problems with the other network hardware. If you're still having problems and it definitely works on other devices then there is something going on with your computer.

The best way to reinstall drivers is to download them, then go in to device manager and uninstall the drivers for the network adapter. Then restart and install the drivers that you downloaded. 

Is your network card configured manually or is it set to auto? if it's manual then set it to auto and see if the problem still exists. If it's auto then set it to manual and put in the same info that works on your laptop (but with a different IP address) make sure you set the IP address (same as your laptop but change the last number), subnet mask (this will usually be, gateway (this is your router) and DNS server (this is also your router).

I haven't reset it to default but I've unplugged it but that usually only solves the little problems haha. I've noticed now that this problem only happens for the the first 15 to 20 minutes though and after that it's all fine. It's almost like it's slowly connecting and getting faster 1 Mb at a time. Although if I click on chrome really quickly before my PC has fully finished turning on it will be full speed, just for like 20 seconds and the it'll start the 'warm up' process or whatever it is. 

Ok i'll try restarting my PC to see if the problem happens again. I've added some more info in a reply I sent to Mystery Angel bellow. Also I ran a test of some sort and it said it was a DHCP router.

Is there something else on your computer which could be using the bandwidth?

Well it's been a few days of testing and it appears that 'pinterest' or something might be causing it, it's software to do with openvpn. It takes a few seconds after boot to start (hence why the internet is full speed for a few seconds after boot) and then when I exit it my internet gets back up to speed again (literally, it takes a minute, gradually getting faster). But why? I haven't connected to anything with it yet, it's just sitting there waiting to be used..

Have you scanned for malware?   I know dumb question ...

Pinterest has nothing to do with openvpn, just uninstall it if you're not using it. 

Face palm on my behalf haha, I meant private tunnel.. I do not know how I got that mixed up haha.

Hmm, so the software you got from private tunnel is using up your bandwidth even though you're not connected to their VPN? Kinda strange. Are you sure it's not connecting to the VPN?