Return to Level1Techs.com

Lm-sensors on Gigabyte X570 I AORUS PRO WIFI

Hi all,
I recently put together my new system.
Ryzen 5 3600X + Gigagyte X570 I AORUS PRO WIFI
Does anyone found what sensors are on that board?

I run gentoo with gentoo kernel 5.4.2
and tried different drivers in the kernel but still sensors-detect finds nothing.
Thanks

X570 AORUS Master + Opensuse Tumbleweed w/ kernel 5.4.2. Tumbleweed’s version of the it87 module seems to do the trick as in it gets a result, by no means guaranteed to be accurate. Haven’t tried the zenpower driver yet.

$ sensors

it8792-isa-0a60
Adapter: ISA adapter
in0:          +1.79 V  (min =  +0.00 V, max =  +2.78 V)
in1:          +0.67 V  (min =  +0.00 V, max =  +2.78 V)
in2:          +0.98 V  (min =  +0.00 V, max =  +2.78 V)
+3.3V:        +1.68 V  (min =  +0.00 V, max =  +2.78 V)
in4:          +1.79 V  (min =  +0.00 V, max =  +2.78 V)
in5:          +1.18 V  (min =  +0.00 V, max =  +2.78 V)
in6:          +2.78 V  (min =  +0.00 V, max =  +2.78 V)  ALARM
3VSB:         +1.67 V  (min =  +0.00 V, max =  +2.78 V)
Vbat:         +1.57 V  
fan1:           0 RPM  (min =    0 RPM)
fan2:           0 RPM  (min =    0 RPM)
fan3:           0 RPM  (min =    0 RPM)
temp1:        +45.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp2:        -55.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp3:        +43.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
intrusion0:  ALARM

k10temp-pci-00c3
Adapter: PCI adapter
Tdie:         +45.9°C  (high = +70.0°C)
Tctl:         +45.9°C  

amdgpu-pci-0a00
Adapter: PCI adapter
vddgfx:       +1.00 V  
fan1:         696 RPM  (min =    0 RPM, max = 3200 RPM)
edge:         +65.0°C  (crit = +94.0°C, hyst = -273.1°C)
power1:       24.05 W  (cap = 150.00 W)

iwlwifi-virtual-0
Adapter: Virtual device
temp1:            N/A  

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +16.8°C  (crit = +20.8°C)

I tried it87 driver, but then it gives me:
modprobe: ERROR: could not insert ‘it87’: No such device

either my MB has different hardware or gentoo flavor of the kernel is missing something

Seems to me there was a linux version of wattman that could pull all the sensor data. I think theres a xotch fix with a kernel mod.

If I can remember this later I’ll look it up for you. ATM I’m helping family move.

Theres a thread hereomewhere on it. I thdnk @FurryJackman made the thread? He’d know how to get sensor data, anyways.

it87 was discontinued and deleted. You’ll need to find a surviving fork of it because the original creator gave up. Older chips will work, but newer chips will fail because nobody is contributing code to it since the original source code has been deleted.

The SuperIO chip appears to be the ITE IT8688E. There’s a Github issue on it, but since the source code was deleted… yeah…

I see …
Thanks for sharing the info.