Return to Level1Techs.com

Linux VM's in VirtualBox

#1

Hi,

I have a new work laptop with Windows 10 as the host and want to move my current Linux Mint VM from my existing laptop which is also a Windows 10 host to my new laptop, the VM resides on VirtualBox.

I have performed the Export feature on VirtualBox and saved the .ova file. I have installed the latest version of VirtualBox on my new laptop (same version as on my current laptop) and imported the VM.

However, when I try to run the VM it hangs and eventually it will go to an intrafms prompt. To rule out my existing VM, I installed a fresh build of Ubuntu 18.04.2 and all seems to run fine until I install Guest Additions, then the system seems to loose performance and eventually crashes. I also have problems trying to get back in to Ubuntu once this happens

I have checked that Virtualization is enabled in the BIOS, uninstalled and re-installed VirtualBox and Extensions and the issues are still happening. I have even tried copying the existing Mint folders to the new machine but this makes no difference.

Any advice is appreciated.

Thanks,
JLR.

0 Likes

#2

I’d run some hardware/memory tests on your new laptop to rule out hardware problems before bothering to do anything else.

You haven’t done anything wrong (import/export should “just work” as you performed it) so as far as i’m concerned it is not a virtualbox problem… so i’d be double-checking the new hardware isn’t DOA in some way first.

0 Likes

#3

Hi @thro,

Hardware on the laptop seems to be fine. I’ve been trying to work it out over the weekend and I have managed to get it to boot in to the VM by enabling the “Host I/O Cache”, but when I shut down the VM it takes ages and VirtualBox hangs.

I have tried to install a previous version of Virtualbox 6.0.4 to rule that out but the same is happening.

Its just weird I can only seem to get somewhere by enabling the “Host I/O Cache” where as this is not enabled on my other laptops and the same image seems to run fine, both starting up and shutting down.

Also disabled McAfee to see if that made a difference but unfortunately it didn’t.

0 Likes

#4

Try copying the actual virtual hard disk to a usb drive onto the new laptop, in virtualbox, create a new machine and attach the existing hard disk to the new machine, do not copy over any of the attributes of the old machine, just the actual VDI, VHD, VDMK file.

Good luck!

Chaos

0 Likes

#5

Depending on what you wanna do with the VM either LInux subsystem for windows or vagrant might be good options. But the choice of Linux Mint kinda makes me feel you dont just need a terminal, but want a true UI for trying whatever.

But seems like your problem is with the virtual box guest additions then. Can you uninstall them from the ubuntu vm on your old pc and then try to export that? Not sure how you do that since Ive never done it but google seems to suggest there is an uninstall script on the disk you mount in ubuntu.

0 Likes

#6

Hi Chaos,

Thanks for the reply, I tried copying the VDI only but still no luck unfortunately.

0 Likes

#7

Hi @maximal,

Thanks for the info, I will look in to it.

0 Likes

#8

Hey, @JLR I might have a solution for your problem with Virtual Box, I first would completely remove VirtualBox from the host system, then reinstall the latest version of Virtualbox, recreate your virtual machines, then install the latest version of Virtualbox guest add-ons. When I wanted to upgrade to 6.0 from 5.2, I had to do as I suggested in the previous sentence.

1 Like

#9

Hi @Shadowbane,

Thanks for the info. I have already done that. Currently running the latest version of VirtualBox, Guest Additions and the Extension Pack.

1 Like

#10

Glad you were able to fix the problem, I have found working with Linux Mint and Virtualbox Guest Additions, works better than trying to work with Ubuntu and VirtualBox Guest Additions. Just thought I would share a little quirk between Ubuntu and Virtualbox Guest Additions.

1 Like

#11

It turns out the problem was the Enable Host I/O Cache under Storage was unticked in Virtualbox. As a shot in the dark I thought I will try enabling it and when I did the VM sprung into life which was great but I noticed Shut Down times was taking ages.

There has since been an update to VirtualBox (6.0.8) and I am happy to say that when I installed that it improved the Shutdown time dramatically.

I am not sure why the Host I/O Cache has to be ticked when using a VM on this laptop as all my other machines that I use VirtualBox on run faultlessly with this option disabled as it is by default. Only thing I can think of is it may have something to do with Hyperthreading being on in this laptop and without this option enabled it just doesnt work properly, but cant really confirm this.

Well, it works. So I’m happy :grinning:

0 Likes