Return to Level1Techs.com

Linux on Virtual Box on a Windows Surface book 3

not sure if this is the right category, but I have a question about the surface book 3. I just picked one up as my new system, but I ran across a problem with trying to install a VM using Virtual Box as the software. but I keep getting errors that stop me from installing. I have tried installing Ubuntu 20.04, and Fedora 32. is this a situation where the Distro doesn’t play well with the VM software or is this a Situation where the surface book 3 wont handle any Virtualization? also if this is the Wrong channel to bring this up on, please let me know the correct one. thank you.

What errors are you getting?

1 Like

It’s very possible that the VMs aren’t launching/running because one of two things (this is speculation until we know which errors you are getting):

  1. Virtualization is turned off in the BIOS. I have seen that this is not as straight-forward as one might hope, but here’s something I found on Reddit that may help you. (https://www.reddit.com/r/Surface/comments/8c1t9i/virtualization_on_surface_laptop/)

  2. Hyper-V is enabled (I think the Microsoft devices come pre-installed with Windows 10 Pro but feel free to correct me. If Hyper-V is enabled it doesn’t like to play nice with VirtualBox.

Ubuntu 24.04 should run with no problems because I have it running currently and have been for a course over the past week. Please provide an update after you’ve tried the above steps or if you can provide us with more specific errors. Thanks!

unfortunately the Surface book 3 comes with Home, not pro. I looked around the Bios, and didn’t find anything in there that mentions virtualization. reading through the redit post here, and some others that I found. my options seem to be rather limited. I may need to fork over some money for a Pro license in order to just use Hyper-v. or there may be some issues with windows Defender that my be causing the issue. thank you.

after booting the Ubuntu 20.04 Iso into the VM it tells me from within the VM that there seems to be some kind of error. it gives me no specifics past that. when trying Fedora I get it to launch into the Gui now after tweaking windows Defender, however it seems to keep failing to install Fedora onto the Virtual disk.

a quick reply, did some trouble shooting and it seems the issue is the installers are not able to write to the Virtual hard disk. I just tried installing linux mint and encounted an error that it in not allowing me to write to the hard disk.

using Linux mint, I am able to load into the live media, however I am not able to interact with the hard disk in any way. I am still not sure if this is some kind of security protection, or some kind of Error ov Virtual Boxs part.