Linux not following B450 Aorus Pro BIOS voltage offset setting

Hello, I just bought a Gigabyte B450 AOURUS PRO motherboard paired with AMD Ryzen 5 3600. Everything is running fine until I decided to do a small overclocking.
I’m using Manjaro Linux with kernel 5.4.13. When I use the default BIOS setting, here’s what I see in sensors (using zenpower kernel module):

  • Ryzen 5 3600 is running on 1.4V under load with 3.95GHz (using performance governor)
  • Ryzen 5 3600 is running on 0.9V idle with 2.2GHz (using conservative/powersave governor)

I find 1.4V is too high so I decided to boot Windows in external HDD and here’s what I see in Windows:

  • Ryzen 5 3600 is running on 1.3V under load with 4.00GHz
  • Ryzen 5 3600 is running on 1.1V idle with 3.50Ghz

I find it weird, so I do a lot of fiddling with motherboard BIOS, changing the voltage offset to -0.05V and Linux is finally running on 1.3V ish under load.

Now, here’s the problem. I tried overclocking the frequency to 4.0GHz with +0.300V voltage offset and booted Linux (can’t get Linux booting at 4.1GHz and +0.300V is the limit Gigabyte BIOS allows). And guess what, sensors shows that I’m on 0.9V voltage with 4.0GHz frequency, running stress test immediately shut down my computer. Then I boot into Windows with the same BIOS setting and Windows booted fine with Ryzen Master reporting 1.4V voltage with 4.0GHz, I can even set the frequency to 4.2GHz fine with Ryzen Master with that setting.

So, I hope somebody can enlighten me with this. Also I want to note that I tried every CPU frequency governor in Linux:

  • Performance, all cores running full speed with 1.4V voltage
  • Ondemand, all cores going up and down (mostly up) with 1.4V static voltage (wut??)
  • Conservative, all cores going down until I do stress command with 0.9V idle and 1.4V load (the most normal governor for me
  • Powersave, all cores stays at 2.2GHz with 0.9V static voltage (as it should be)
  • Schedutils looks like ondemand, weird stuffs displaying on sensors.

Also, here’s what I’m using to monitor sensors (changing back and forth):

  • watch -n 0.5 sensors zenpower-*
  • ${color2}CPU Core Voltage ${alignr}${color0}${hwmon 0 vol 1} V using conky
  • using Zenmonitor

That’s it for today. I hope somebody can help me with this. Thanks before. Btw this is my first post here, been a subscriber of L1Tech on Youtube since the beginning :slight_smile:

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.