Linux Mint Virtualized in ESXi with GPU Passthrough Problem

Situation:
-Server is Running ESXi
-Server has Linux Mint VM
-Linux Mint VM has USB 3.0 PCIe Card and Quadro fx1800 passthrough to the VM
-USB 3.0 card works perfectly
-Quadro does not

Is there something I am missing that is causing problems with drivers? After a fresh install I can get about 1 second of video out from the card during boot up but then Linux mint says that its running video off of the CPU.

Tried:
-Removing 3.0 card passthrough
-Fresh install 5 times
-More RAM (10GB Total is all my server can spare)
-Both nvidia and noveau drivers
-Yelling at it to get its act together
-Tested video card in non virtualized environment with same version of linux mint (works just fine)
-Disabling svga.autodetect and svga.present
UPDATE:
Tried LMD3 the debian version of mint and also didnt work.

I’m fairly new to Linux, ESXi, and Virtualization but I’ve spent a good few hours trying to find someone who has had a similar problem on various forums. Any guidance or advice is greatly appreciated.

I can’t be much help, as I’ve never done passthrough, but to my knowledge, Nvidia cards are hard to get playing nice with VMs and passthrough.

I’ve heard that, but I thought that quadros were designed with this in mind?

Quadros? Don’t think so? They’re workstation cards. Pass-through is a datacenter thing and i suspect you’re needing Teslas for that*.

  • officially

Quadro drivers don’t have the code 43 gimping of the gaming drivers.

Quadros are probably the best cards to use for passthrough as most AMD cards have the reset bug, lower end nvidia cards have code 43 and teslas mostly don’t have display outs.

1 Like

I stand corrected

Since you can boot the thing I assume you checked “Reserve all guest memory (All locked)”?

Maybe remove the other graphics card from the VM so it only has the quadro?

all memory is reserved yes. The only other video out is the onboard video out and you remove that my going into advanced settings and turning svga.present to FALSE. Which works but then I loose all video out. Even remoting in through esxi.

Does it work with any other Linux distro, what if you boot into the VM bios?

No video out when in bios, but upon initial installation I can get the Linux Mint loading icon to show up for about a second before it looses signal

havent tried it with any other distro other than ubuntu yet but I’m pretty sure they both use the same drivers, I’m gonna try LMDE3 when I get home to see if that changes anything.

Can you find the additional displays and display adapters in the display setup in Mint?

Does it show up as if you type lspci | grep VGA ?

it only shows the virtual display even after I hit detect displays.

That command returns:
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
03:00.0 VGA compatible controller: NVIDIA Corperation G94GL [Quadro FX 1800] (rev a1)

did you also pass through the HDMI audio controller (same bus address different last digit)

Theres no audio controller that I can see in the list of hardware

ODD

On the more “gamer” oriented cards it’s there.

Its address “should” be 0000:04:00.1 based on your screenshot

EDIT:

I looked up your card: https://www.techpowerup.com/gpu-specs/quadro-fx-1800.c1323

DAMN; that’s OLD

Nevermind it doesn’t have HDMI Out so why would it have an HDMI audio controller, sorry I’ll shut up :slight_smile:

old yes, but it was free.

How is the bios on the server setup with regard to igpu and pcie gpu?

I’m thinking so that VMWare doesn’t use it for it’s very limited GUI?

I’ve been experiencing the same thing trying to get any debian linux distro to work and display with my 1080 ti on ESXi. Enabling the hypervisor.cpuid.v0 = FALSE doesn’t let it show up. Works fine in windows 10 for whatever reason. I wonder if theres aome kinda mismatch between how vmware presents the PCIe device and how linux tries to map it, like if linux doesn’t let it change based on what vmware tells it to be and just ignores that

I have a similar issue OP, I would like to physicalize a Linux VM more so than my current win10 but it has just been a reminder why the ‘why don’t people use Linux more?’ threads exists.

I tryed the stuff in this guy’s build to no avail
https://elatov.github.io/2018/04/esxi-65-passthrough-video-card-to-plex-vm/

Maybe it will help you.