Return to Level1Techs.com

Linux Mint, Disable Automatic Login

Hey,
I hope this post finds you well.

I am using Linux Mint 19, and I just installed it today.
Therefore, I am quite new to using Linux.
I am having an issue, and I cannot find an appropriate answer on Google.

So here is the issue I am having, I reboot my laptop, and my laptop boots up Mint 19, and automatically logs into my administrator account.

I want to disable this automatic login, and be prompted to enter my password upon reboot.

If anyone has a solution to this problem, I would be very grateful.

Thanks,
M

EDIT:
I eventually found a solution.

Open Terminal.

Open the following file.
sudo nano /etc/lightdm/lightdm.conf

Enter your password.

I changed the contents of the file “lightdm.conf” to the following…

[Seat:*]
autologin-enable=false
autologin-guest=false
allow-guest=false
greeter-show-manual-login=true
autologin-enable=false

I saved the file and rebooted.

The issue was resolved, and I was prompted with a login screen upon reboot.

Edit /etc/mdm/mdm.conf and change:

AutomaticLoginEnable=true

to

AutomaticLoginEnable=false

Thanks so much for your reply, sadly, that result from Google does not provide me a solution.

Pretty sure there’s a “Users” applet in Mint’s Settings (on Cinnamon; Control Center on MATE) tool where you can do this via a GUI, in case this comes up again. You’ll likely need to click the “Unlock” button and provide your password.

There was a group called nopasswlogin.
I deleted the group, however the issue still persisted.

Thanks for this, just spent hour trying to find a solution to this problem and like you said google was no help at all.
Your solution worked.