Linux black screen on bootable usb

Trying to install arch on my PC. I7 4790k gtx 970. I get a black screen after boot arch Linux option. I see forums on how to Dixit l, they say change the GPU settings modeset but how do I get to this option. I know u can change it in grub by pressing e. Different Linux distributions aren't working unless I run fedora in low graphics mode
Some others are working some aren't. It only works in bios boot if I run uefi boot this domes up.

What you could do is connect your monitor to your mobo, I think that should start Arch... I've had this happen with various distros as well.. Fedore and CentOS for example. When installing and/or running Manjaro, I realized it included a "free" version and a "proprietary" version or smth.. And it confused me until I realized that it meant the free one was using free drivers and the prop was using nvidia drivers and that is the on that I could run with my monitor plugged into my 960.

After installing you can download the drivers of your gtx and plug it back.