LG Gram Fan control

I have an LG Gram 17inch 2020. it is over heating.

I found /sys/devices/platform/lg-laptop:drwxr-xr-x 4 root root 0 Oct 28 12:09 .
drwxr-xr-x 33 root root 0 Oct 28 12:08 …
-rw-r–r-- 1 root root 4096 Oct 30 02:15 battery_care_limit
lrwxrwxrwx 1 root root 0 Nov 2 13:24 driver -> …/…/…/bus/platform/drivers/lg-laptop
-rw-r–r-- 1 root root 4096 Nov 2 13:24 driver_override
-rw-r–r-- 1 root root 4096 Nov 2 13:28 fan_mode
-rw-r–r-- 1 root root 4096 Nov 2 13:24 fn_lock
drwxr-xr-x 4 root root 0 Oct 28 12:09 leds
-r–r--r-- 1 root root 4096 Nov 2 13:24 modalias
drwxr-xr-x 2 root root 0 Nov 2 13:24 power
-rw-r–r-- 1 root root 4096 Nov 2 13:24 reader_mode
lrwxrwxrwx 1 root root 0 Nov 2 13:24 subsystem -> …/…/…/bus/platform
-rw-r–r-- 1 root root 4096 Nov 2 13:24 uevent
-rw-r–r-- 1 root root 4096 Oct 30 02:15 usb_charge

i cant echo into fan_mode, even with sudo and pipe magic “echo “1” | sudo tee fan_mode”

even without errors after a echo, when i cat the file it is unchanged. i maybe in the wrong area. how do i increase the speed of the fan??

Have you replaced the thermal paste? My HP Pavilion 13 AN007NU on Linux overheats as well so you’re not alone there. Intel’s DPTF isn’t fully-implemented yet. You can try updating your kernel to 5.8 and above if not already as those should have some improvements around that feature.

Its only a few months old. the fan is locked to “Silent” mode, maybe it is reaching 100% fan.

regardless, worst case is i can just stop playing games on it and build a computer. outside of games it is an awesome laptop

you have data on how it works on windows?

because laptops generally overheat when gaming as far as I know, might be wrong tho

im starting to think that its just bad design, it will red line 90C playing among us.

im going to just task a computer to this, use another display and remote that computer for control via VNC / fake display making the other computer act as tho its a display above my laptop if i mouse up.

im going to keep this post up for another day just incase someone else knows how to change that kernel module. it has no parameters, so i dont think i can change the fan settings… but maybe?

1 Like

on windows I can controll my fan speed for my dell laptop on HWinfo64, I think there is a linux version
https://www.hwinfo.com/

Perhaps just changing the SMBIOS thermal mode will alleviate your issue? This worked on my laptop:

[email protected]:~$ sudo smbios-thermal-ctl --info
Libsmbios version : 2.4.3
smbios-thermal-ctl version : 2.4.3

 Print all the Available Thermal Information of your system: 
-------------------------------------------------------------------
 
Supported Thermal Modes: 
	 Balanced
	 Cool Bottom
	 Quiet
	 Performance
 
Supported Active Acoustic Controller (AAC) modes: 
 
Supported AAC Configuration type: 
	Global (AAC enable/disable applies to all supported USTT modes)
[email protected]:~$ sudo smbios-thermal-ctl --set-thermal-mode performance
Helper function to Set Thermal Mode
Thermal Information Set successfully to: performance
[email protected]:~$ sudo smbios-thermal-ctl --get-thermal-info
Helper function to Get current Thermal Mode settings

 Print Current Status of Thermal Information: 
-------------------------------------------------------------------
 
Current Thermal Modes: 
	 Performance
 
Current Active Acoustic Controller (AAC) Mode: 
	 AAC mode Disabled
 
Current Active Acoustic Controller (AAC) Mode: 
	Global (AAC enable/disable applies to all supported USTT modes)
 
Current Fan Failure Mode: 
1 Like

I was able to change the fan mode out of “silent”. Sometimes it gets stuck, and I have to reboot to change it. However, just turning “silent mode” off doesn’t make the fans change speed according to the temperature, as it is still at a low setting. When I use it in Windows the fans rev up much higher.

:thinking:

Well, to manually control the speed directly on my laptop (Dell Inspiron), I have to use i8kctl, but the fan only responds to that command for a single moment, meaning that I would have to spam i8kctl -1 5000 indefinitely for the fan to stay spinning at around 5000RPM, which is why I just changed the SMBIOS profile and called it a day. I’m guessing that the LG Gram is similar in that respect, but ¯\_(ツ)_/¯

You were able to change the fan mode in linux or windows?

Also how were you able to do this? and what kernel was this on?

When it works ( which it doesn’t always) I do
sudo echo “1” | tee /sys/devices/platform/lg-laptop/fan_mode
After which I can barely hear the fans. I double -check my change by
cat /sys/devices/platform/lg-laptop/fan_mode
and if that outputs 1, then I know it worked. If it doesn’t change, I reboot and it will sometimes work the next time I try.
I am on kernel 5.9.13-arch1-1. I think the SMBIOS profile is dell-specific, because when I run
sudo smbios-thermal-ctl --info
It outputs “ERROR: Could not execute SMI.”, followed by some suggestions that involve Dell drivers.

Oh :sweat_smile:.

Correction: The command I use that sometimes works has sudo in front of tee
echo “1” | sudo tee /sys/devices/platform/lg-laptop/fan_mode

yep, the echo “1” would pass the same 1 regardless of privilege but placing that 1 one /sys/devices/platform/lg-laptop/fan_mode will need sudo

this is actually the second thing i tried when i found that i could not echo > on to the file, i tried tee, vim, cp over the file. nothing worked. though i did retry the tee command and it worked! , once, 3 days ago and never again, also i could not re-edit it and change back to original state. the change was lost on reboot

I somehow also had the same problem and stumbled upon this thread which seemed like the only place on the internet which addressed this. I was able to successfully write a 1 to turn on silent mode. However, when I did, my computer instantly became sooooo slow. I also had tlp installed so I don’t know if this was interfering with that program? Regardless, I think there’s a reason that on reboot, silent mode is by default off. Maybe it’s just not recommended.

I have an LG Gram 14" laptop with the same cooling issue (fan does not run). It appears that the laptop is set up for fan control by firmware, but once the OS takes over, it seems that the fan isn’t being activated and the computer is shutting down because of temperature.
Interestingly, I ran Windows yesterday after one of these random shutdowns. (It’s dual boot). The fan was quiet while running windows just like in Kubuntu, but when I shut down the computer, the fan ran at a speed that was fast enough for me to hear it for several seconds while shutting down. I take this as proof that there isn’t a hardware problem and the fan does work.
The thermal monitor widget is showing temperatures within normal range, but the temps do spike when doing things that I assume are taxing the GPU.
For example I had a schematic diagram open in Okular and zoomed in to see a detail. While watching the thermal monitor widget, if I pan around in the zoomed document, the temperature was hitting 90 degrees plus, and it did eventually cause a shutdown.
My feeling here is that whatever controls the fan isn’t doing a good job.

I can see 9 cooling devices in /sys/devices/virtual/thermal/
Eight of the nine cooling devices show type as “Processor”, and the last one shows as “intel_powerclamp”
The files in the cooling_device0 to cooling_device8 folders have the following contents (cooling_device0 shown) -
-rw-r–r-- 1 root root 4096 Oct 26 09:33 cur_state
lrwxrwxrwx 1 root root 0 Oct 26 09:06 device → …/…/…/LNXSYSTM:00/LNXSYBUS:00/LNXCPU:00
-r–r–r-- 1 root root 4096 Oct 26 04:36 max_state
drwxr-xr-x 2 root root 0 Oct 26 09:06 power
drwxr-xr-x 2 root root 0 Oct 26 09:06 stats
lrwxrwxrwx 1 root root 0 Oct 26 04:36 subsystem → …/…/…/…/class/thermal
-r–r–r-- 1 root root 4096 Oct 26 04:36 type
-rw-r–r-- 1 root root 4096 Oct 26 04:36 uevent

If I cat the cur_state file, the result shows 0, which I take to mean the device is not active.
Max state is 10
in the stats folder, I can see a summary of running time for these devices and it looks like they have never run, ie. their state has always been recorded as 0.

Any ideas on what else I can try, or a way to take control of the fan?
Has anyone been able to deal with this problem?

The down clock(?) happened to me as well. I assume that is what it was, I was unable to find the reason as the system was so slow I could not use it. A reboot resolved the issue.

I ended up formatting it to windows 10 and giving it to my mother. I will run a CPU stress test on it next time i see her to see if windows has more control over the fan.