Lenovo Ideapad 330s-15ARR [SOLVED]

Im trying to get linux installed on my new Lenovo ideapad 330s -arr, problem is every distro ive tried locks up on boot.

AMD Ryzen™ 5 2500U Mobile Processor with Radeon™ Vega 8 Graphics
Windows 10 Home
15.6” FHD (1920 x 1080) IPS
8gig DDR4
1 x 1 AC WiFi + Bluetooth 4.1
USB Type-C 3.1
2 x USB 3.0 (one charging)
4-in-1 card reader
Audio jack

Anyone got one and had any luck with linux???

I found out through trial and error and a whole butt tonne of googling my error codes i got it done.

So :slight_smile:

  • So update Bios
  • Disable AMD Security chip
  • add iommu=soft to /etc/default/grub, then sudo update-grub2
  • update kernel to 4.20.6 just for good measure

So Hopefully that may help someone else


I have the same laptop and I also have the hanging black screen when trying to install or run the live cd.

Where did you make these changes to get your laptop running?

1 Like

OH SORRY, I have been busy at work/playing ds1 XD

I wait until the screen turns purple then spam the esc key until you get to the grub screen and press e to edit.

go to the line that ends ‘splash —’
and add iommu=soft just before —

1 Like

O that’s cool I got it working a different way. I added a boot pentameter of ivrs_ioapic[32]=00:14.0 after I manually installed Wi-Fi and touchpad drivers. I had to boot with noapic to even install kubuntu.

1 Like