L1 KVM Windows Issues

I recently got the 2 Monitor USB-C KVM switch from the L1 store (not the powered KVM for clarity).

The two computers that are interacting with it:

  • M1 Macbook pro with a dedicated USB-C → DP 1.4 connector plugged into PC 2. Seperate USB-C cable for carrying the USB data. No docking station or anything in the middle.
  • I have a desktop with an MSI Z690 Pro - a, and an EVGA RTX 3080 FTW3. 1m Club3d cable from DP output 1 to KVM. USB -C cable plugged into Fractal Define 7 top panel header.

Monitor: Samsung G9 Neo (5120 X1440p @ 240hz) 1m Club3d cable from KVM to monitor

I can list out any additional components if necessary but tried limit to what I believe impacts it.

M1 the setup is amazing, works like a charm outside of takes ~15 seconds to switch inputs. I can live with this, not looking for any improvements here. The entire reason I got this KVM was for the M1 so that I could use DP from both my desktop and laptop because for whatever stupid reason there is only 1 DP input.

Window Machine, is a current not usable.

  • On switching back to the windows machine, it is very fast compared to M1 except that it doesn’t properly set the resolution or really negotiate anything. Nothing really detects what the monitor is, just forces a 800x600 aspect ratio. Switching back and forth does nothing. The only thing I can do is unplug and replug the DP cable or I can power cycle the monitor. These both reset the monitor and everything is good again.

  • Roughly within 5 minutes of use, the screen just goes dead. Its struggling and flashing like it is trying to power on and off and do something but the monitor I guess is failing to negotiate boot with the graphics card and just can’t. I have to switch the input or unplug the cable. I am unable to get in the middle of this sequence and power off the monitor because every time it tries to boot it kicks you out of the menu.

I am looking for some help in trying to resolve the windows behaviour of pointing me in the direct of where I should be posting for support.

I saw a couple posts in here about the KVM so I figured I should start here.

Thanks for the help in advance.

Symptoms sound like one or more of your cables are borderline.

I’d start with a 3 foot club3d cable between the KVm and the g9 and see how that goes to start.

The long switching time is it negotiating and failing and trying again.

Thanks for the idea @wendell.

I did what you said and no dice. I bought 3 1m cables initially and ran through the permutations of connecting them to the desktop or to the monitor. I continued to have the same experience.

From there, I changed the input/output from the top row to the bottom row for the DP in/outs.

This resolved my second problem of within 5 minutes the screen goes black. This means it is at least usable now, though it makes me pause about trying to get my second monitor involved with this.

As for the switching back to windows machine, I am still running into the same issue of 800x600 force resolution. I need to power cycle the monitor for it to come back alive.

Any more thoughts there? I’ve also run through the permutations after switching the port lines as well and still seeing the same.

I ran into one other user with a Mac getting 800x600 when switching from Mac to windows.

Can you unplug the usbc to dp cable from the Mac and see if switching from “nothing” to the windows PC still triggers it? For them it was something weird their USBC adapter was doing.

Moshi USBC to dp works well as do caldigit docks. What sort of hook up is the Mac using?

The g9 is particularly picky and needs the latest firmware too. Your other display will probably work fine in the top set of ports. The g9 is just special. It can also make a difference which GPU outputs you use.

I should have known I own going in my 5120x1400p dreams were going to cause issues.

I stripped it down so it was just DP ports flipping back and forth, still running into the same issue.

I will look at upgrading the firmware, I was googling around this morning thinking it might be along those lines but haven’t found it yet. I’ll keep digging

No go on the firmware upgrade, now on the latest 1011 still seeing the same problem.

I’ll play around with the DP outputs from the graphics card later on to see if I can make that work.

I also should have my docking station arrive tomorrow and I can see if there is a difference with the output from the mac coming from a docking station vs a usb-c to DP cable.

Once the Mac cable is out of the equation if you reboot the KVm (power cycle) I’d be surprised if it reverts to a lower res.

I have the same monitor /firmware /setup here and it doesn’t do that.

1 Like

So I have updated everything I can get my hands on at this point.

  • GPU VBOIS
  • MOBO BOIS
  • Monitor Firmware
  • Windows (latest patch but on 21H2)

I also removed USB entirely from the question and power cycled the KVM for 10 seconds a couple of times. I didn’t find any power buttons or anything so I pressed the switch a couple times hoping maybe that drains any residual power.

I had no change in the behaviour. When switching from Mac input to windows I get the 800x600 resolution unless I power cycle the monitor.

Here are some thing I have gone through and the impact they have made.

  1. Removing the Mac and having a blank output
    • KVM works correctly and returns to the correct resolution
  2. Switching the GPU output to each one of the 3 outputs and power cycling KVM between attempts
    • No Change
  3. Turning off Adaptive Sync on the monitor
    • Monitor detects no output and turns off when switching to windows. Turning on the power to the monitor again restores correct resolution
  4. Changing refresh rate (240, 120 and 60Hz), on/off HDR
    • No Change

I out travelling the next couple days, but the last thing I can think off and I am going to do is replace my graphics card and see if that resolves the issue.

Ok massive progress on this front, display seems to be switching properly now. Full HDR and Adaptive sync enabled.

Moral of the story is don’t buy cheap USB-C to DP accessories off of Amazon. I was using a CABLEDCONN USB-C to DisplayPort 8K cable, and while it was working fine alone it was the root cause of my issues switching to between the Mac and Windows machines.

My TS4 from Caldigit arrived today and everything is working great now on the DP front. It is able to switch connections between and keep the resolution properly.

I am happy to do any additional testing anyone might want, but I am happy to just throw this connector in the trash as well.

Two oddities that I am experiencing to give to future people fighting things.

  1. My G502 does not work unless it is plugged into the non-HID ports on the KVM
  2. My Keyboard does not work on the HID ports when connected to the Data only output on the TS4. I must have the USB-C connected to one of the ports that is supplying downstream power.

Are these two caveats expect @wendell or have I found something else new that I should spend some time figuring out. Its working for now, but I would rather get everything solid if this isn’t expected.

1 Like

I think thats what we’ve got here and it works hid or non-hid. Firmware up to date? Sometimes you need to have the software loaded on ALL PCs (or NO pcs) for the hid ports. usb3 is a hard switch

this might be a usb hub depth problem since hid is downstream of the internal usb3 hub in the kvm. this is not always an issue, but can be.

yay glad its working!

Yes, usbc to dp is usually garbage. Doing it via dock now? I’ve tested with TS3+ heavily and had many reports of caldigit TS4 working fine, too.

Moshi is probably the best brand of usbc to DP cable that I’ve found. Most of those cables assume they will attach to a monitor, directly, not be coupled to a KVM. Moshi because it is bidirectional cannot make any such assumption.

Yeah, I am doing it via the dock now. TS4 has been on backorder for months, I just got lucky that they are finally available again as this USB-C to DP cable was always an interim fix. Happy to just be rid of it.

No luck on the firmware update, there was no logitech software installed before I did the update so I was definitely in the No PCs camp. The G502 doesn’t even light up, its like it isn’t connected or getting power.

Its fine, I don’t need the USB3 slot on the back and I have spare downstream power on the dock so its all good.

With this working, I can say the only feature that would have been nice to have is a USB-C input on the front side so I could plug in my yubikey with the USB-C connector. I know you guys aren’t the manufacture but passing it along encase its useful.

Honestly, thanks for all the help. I know it ended up being hardware and some hair pulling but you were super prompt and I honestly didn’t expect you to help directly. I honestly enjoy being able to support companies like yours and wish you the best and I look forward to seeing what comes next.

Thanks. I have a lot more input on what we do for product hw than you might think because I manage all the customers world wide :smiley: