L1 KVM USB concerns

I picked up a L1 KVM (triple monitor, 5Gbps, 2 PC option) about 5 months ago and since the start it’s given me a small issue.

Every now and then, my PC will lose USB connection to my keyboard and mouse. I’m not unfamiliar with such problems, I work as an IT admin as part of my day job. That’s actually the reason I picked up the KVM. I started a new job working from home and I wanted to use the same displays, KB, and mouse for both my work and home PC use. Work furnished me with a Lenovo laptop with a thunderbolt dock, the dock has 2x display port and one HDMI. I used a recommended HDMI to displayport adapter and I was off to the races. I’ll be clear here: the Lenovo has zero issues. It works flawlessly apart from some small display issues when I switch the KVM over to it, usually requiring a power cycle of a display. I expect that’s more of a display problem than anything.

The issue is with my personal rig. I have a Dell precision 7910 rack as my own computer (it’s crazy to use it as a desktop, but I have my reasons). The problem is that it doesn’t have USB 3.0 available on the back, so I added a USB 3.0 controller for the purpose, but the precision doesn’t really have the usual power headers inside the case, so I found one that works off of PCIe bus power only, and so far (prior to the KVM issues) it’s given me no issues. Enter the KVM. Now, every so often, usually when I’m playing games, I’ll get notification tones from Windows (W10 pro) that a device has disconnected. A second later it will reconnect with the appropriate tones played as well. During that 1-2s of downtime, the keyboard and mouse are quite simply dead. Unable to be used. This poses a problem when gaming, as you might imagine

For completeness, my keyboard is a fairly standard mechanical from CM Storm. My mouse is a Logitech G703, and I’m using the power play matt thing to keep it charged. Also on USB from the KVM is a displayport dual adapter (to add two more displays, yes, I have five in total). I suspect the powerplay mat is pulling too much current for my poor USB card, and it resets the port, but the displays don’t seem to have any issues, though further testing is required here.

I managed to check my power draw on my personal system’s usb line, and found that an attached USB drive was pulling more power than the line to the KVM. I pulled the drive thinking that may reduce the power load and fix the problem, but it didn’t.

For those not familiar, the power play matt from Logitech functions both to wirelessly charge the mouse, and also acts as the wireless reciever for the mouse, so simply plugging it in elsewhere isn’t an option. I tried plugging it into the hid ports on the KVM, and the USB 3 ports on it and neither seems to make any difference. The only other thing on the KVMs USB is a verifi fingerprint scanner, which was recently added, the problem existed before it was added.

Nothing is appearing in the windows logs when it happens. Not even device plug/unplug messages IIRC. No errors from the USB controller driver… Nothing. I’m at a loss.

I’m hoping someone from the L1 forums here can help me brainstorm new ideas to try on order to fix the problem, and what may be the cause. My only idea right now is to butcher a USB cable to inject 5v power to the mouse to see if it fixes the issue (either between the mouse and KVM or between the KVM and PC). Given that my work system has no such problem, I’m more inclined to think it’s the USB card on the PC that’s the problem, so I would probably want to inject power between the PC and KVM.

The “plan” (if you can call it) is entirely based on the fact that the KVM is drawing more from the USB port than the port can deliver, but without issues from the USB attached displays, I’m not sure. It’s possible that the display link connected displays are not affected because they just keep showing whatever is in the framebuffer while the PC sorts itself out, which is why I need further testing on that front.

I would think that this is just too much for the KVM to handle, except, why would the Lenovo work fine if that was the case…

Any further ideas or suggestions are appreciated.

the hid ports and usb3 ports are setup differently; you can use a powered usb hub on the usb3 ports (but, ideally, not the hid ports).

most of the time this kind of thing is down to one particular device that is in hid mode most of the time, but goes out of hid mode sometimes. going out of hid mode in a hid port is not good in the context of a kvm, but it’ll work fine via usb3. power cycle the kvm, move peripherals to the usb3 side of the kvm one or a few at a time, optionally via a hub, and that likely clears it up.

Hi Wendell,

Right now the only device that’s on the HID side is the keyboard. a bog standard CM Storm QFR keyboard. About the only fancy thing it has is a bunch of function keys for play/pause/volume; I’m not sure that would be causing it to pop out of HID mode at any time (which doesn’t explain why the lenovo doesn’t have a problem in either case). I have no special software installed for it.

To me, that would make it seem like my problem isn’t the KVM at all. Prior to having the KVM, my USB was very differently configured; my kb/mouse were connected to USB 2.0 on my PC, and the USB 3.0 PCIe card was only handling my external drive, and some other fairly minor peripherals (camera, and occasionally my phone and some other things)…

With this new information I am strongly suspecting that the USB 3.0 card in my desktop PC is the culprit. Why I’m not seeing anything in the logs is anyone’s guess; probably a driver problem.

I’ll look into it. I have other USB 3.0 PCIe adapters, so maybe I’ll try using a different one and see how it goes… otherwise I’m butchering a cable to reduce the power load on it to see if that helps.

I will do my best to come back and post whatever worked.

I appreciate the help. Have a great day.

Quick update: looks like changing the USB adapter card worked.

I first tried buying a fairly inexpensive Sabrent powered USB hub, which did not fix the issue, but I was able to move the connection from my PCIe USB adapter, to an internal USB A port on the system (the only USB 3.0 port is internal, go figure), and it hasn’t dropped since.

Now my only issue is windows related, it won’t always pick up the USB-attached displays, though the mouse is on the same HUB, which it almost always picks up (when switching between sources), and the fact that one of my systems keeps moving all my windows to the primary screen every time I switch away from it.

Minor issues overall, and bluntly, not the fault of the KVM.

Thanks for the assist Wendell!

Have a good day everyone.