KVM unable to install Windows 10 build 1803 as a guest

Am I the only one experiencing this? Build 1607 installs fine. Build 1803 BSODs immediately when trying to install. I downloaded the image twice on 2 different computers from MS to make sure my ISO wasn’t broken.

ISO is fine.

What options are you using in libvirt? UEFI? Q35 or i440? virtio or sata? CPU model? CPU topology?

UEFI i440, with Marvell Sata card passed through. I have tried installing on the ssd, then passing it through (as part of the sata card) and I have tried installing in Virt Manager with the .iso image method. When trying to boot a working win10 1804 ssd, it BSODs. When trying to install the .iso, it BSODs.

Try switching to Q35. It’s got better support for PCIe

Just tried q35. Same result, BSOD

Try changing your CPU type. I have a similar issue with libvirt when using ‘host-passthrough’ mode for the CPU. Switching to virtually anything else makes the BSOD go away.

ok, I was already wondering if I’m the only one having problems with 1803 right now.
After the update the system doesn’t boot anymore with qemu at all and keeping one or two cores at 100% load on the host

any news here? Someone else ran also into this problem?
Does someone have a running 1803 in qemu/libvirt?

I’ve updated to 1803 without issue. Aside from the usual bullshit of MS resetting all my preferences.

Here is my config if it helps…

<domain type='kvm'>
  <memory unit='KiB'>8392704</memory>
  <currentMemory unit='KiB'>8392704</currentMemory>
  <vcpu placement='static'>4</vcpu>
    <vcpupin vcpu='0' cpuset='4'/>
    <vcpupin vcpu='1' cpuset='5'/>
    <vcpupin vcpu='2' cpuset='6'/>
    <vcpupin vcpu='3' cpuset='7'/>
    <type arch='x86_64' machine='pc-i440fx-2.11'>hvm</type>
    <loader readonly='yes' type='pflash'>/usr/share/ovmf/x64/OVMF_CODE.fd</loader>
    <boot dev='hd'/>
      <relaxed state='on'/>
      <vapic state='on'/>
      <spinlocks state='on' retries='8191'/>
    <vmport state='off'/>
  <cpu mode='host-passthrough' check='none'>
    <topology sockets='1' cores='4' threads='1'/>
  <clock offset='localtime'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <timer name='hypervclock' present='yes'/>
    <suspend-to-mem enabled='no'/>
    <suspend-to-disk enabled='no'/>
    <disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='none' io='native'/>
      <source dev='/dev/disk/by-id/ata-WDC_WDS500G1B0A-00H9H0_164407800514'/>
      <target dev='vda' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    <disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='none' io='native'/>
      <source dev='/dev/disk/by-id/ata-KINGSTON_SH103S3120G_50026B722902764F'/>
      <target dev='vdb' bus='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0b' function='0x0'/>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x7'/>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0' multifunction='on'/>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x1'/>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x2'/>
    <controller type='pci' index='0' model='pci-root'/>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x0a' function='0x0'/>
    <interface type='network'>
      <mac address='52:54:00:b3:d6:99'/>
      <source network='default'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x02' slot='0x00' function='0x0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x02' slot='0x00' function='0x1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x00' slot='0x14' function='0x0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0'/>
    <hostdev mode='subsystem' type='pci' managed='yes'>
        <address domain='0x0000' bus='0x06' slot='0x00' function='0x0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09' function='0x0'/>

Thanks for your config @BigBlueHouse. Actually it doesn’t differ too much from mine, except USB-Chipset (but can get rid of it since I passthrough a whole controller now) and machine type, I’m with q35 there.
I will do some testing by time with the little differences.

btw. I tried it with pc-i440fx, but it didn’t work either. The problem is still the Vega passthrough, next point on the agenda will be older BIOS versions. Couldn’t imagine any other reason anymore, as I already tried different kernel versions (4.14 LTS, 4.16, 4.17)