KVM seemingly non-functioning and unresponsive

KVM Model:


USB Interface (5-gigabit or 10-gigabit):

5-gigabit (I think? Not sure how to tell)


The KVM seems to no longer work or respond to button presses. When the power is plugged in, I see the green power light come on. However, there is no red light indicating the selected input (like there used to be). Pressing any of the input buttons does nothing (it used to beep and change the red light). Plugging in a USB cable DOES turn the green light on for the specific input. Nothing seems to be passing through though.

I tried unplugging everything and waiting for a while, but it doesn’t seem to help. Even with only one output and input plugged in (tried different cables, etc). It still seems to be stuck. I have four different computers that I’ve tried but none of them are working with it.

Other Notes:


Youd have to try power brick attached only, o other csbles, after being unplugged fir 1-2 solid minutes.

If it doesnt change inputs with just the power brick and you hsve a light on from the power brick itll need mail in repair or diagnostics. Even out of warranty repair is pretty cheap. Email wendell at level1techs dot com

I would do basic troubleshooting like checking that it hasn’t come unplugged from the wall, if you’re using a power strip make sure it’s switched on, that sort of thing

I left it unplugged all night with no cables plugged in at all, and they tried with just the power cable plugged straight into the wall and no dice. Because the green power light comes on when I do that, I’m assuming that it’s still getting power. Will email. Thanks!

To clarify, the USB 3.0 cable powers the green LED. The KVM does not have to be plugged in through the power supply for the green LED to come on. No red LED means the KVM is not getting power from the power supply, for some reason or another.

1 Like

My last response was following Wendells instructions - In this test, I don’t have anything plugged in other than the power cable to KVM itself. The only light that comes on in this instance is the green one above “POWER”. In this instance, it seems like the issue is consistent with what I will need to mail it in for. Hope that makes sense!

1 Like

Ah gotcha. Makes sense. Hope we can get it sorted for you