KVM problems with passthrough


I’m trying to get kvm working with a Win10 VM and using my AMD vega m passthrough to it.
I followed this guide: https:// youtu.be/gIE9zBtpJw0 (sorry, can’t post links yet) which uses exactly my machine:

Nuc 8i7hvk

This worked beautiful for a few months until I tinkered with it and I had to reset my Fedora installation.
Now when I try to boot my backed up VM without passthrough it starts fine but when I add the vega M to it it just freezes the whole host,
unfortunately the site with the scripts is no longer online and I’m missing some crucial configuration in my kvm.conf file I guess, this is what I have:

options kvm_intel nested=1 enable_apicv=0
options kvm ignore_msrs=1

The VM itself runs fine as long as I don’t passthrough the gpu…
Can anybody help me here?
I cannot even find any error output as the system just freezes as soon as the Graphics driver get initialized (Windows loading points show up and freeze after few seconds, whole system unresponsible)

Thank you very much, I’m trying for 1,5 months now but no solution so far :frowning:

any errors when you load the vfio driver?
what method/scripts are you using to bind vfio?

no errors, I’m not quite clear how vfio gets loaded,
but this is the qemu hook from the tutorial:

systemctl stop firewalld
echo efi-framebuffer.0 > /sys/bus/platform/drivers/efi-framebuffer/unbind
echo 1 > /sys/bus/pci/devices/0000\:01\:00.0/remove
echo 1 > /sys/bus/pci/devices/0000\:01\:00.1/remove
echo 1 > /sys/bus/pci/devices/0000\:00\:1f.3/remove
echo 1 > /sys/bus/pci/devices/0000\:00\:14.0/remove
echo 1 > /sys/bus/pci/devices/0000\:00\:14.2/remove
echo 1 > /sys/bus/pci/rescan
cpupower frequency-set --governor performance

i can see that the gpu is not used by any driver at all when i start the vm with vnc only
I also tried with manual loaded vfio drivers (kernel cmdline with pci ids) at some point and this also works without problems but the issue is the same