KVM Not working as expected. What am I doing wrong?

Hello!
I have recently build my PC with Ryzen 9 5950x, Gigabyte x570 aorus xtreme motherboard, and due to GPU shortage, settled for Sapphire NITRO+ RX 5500 XT. I have it setup as an Unraid server, and running VMs from it. I purchased the 4 Port Display Port 1.2 KVM Switch - Dual Monitor back in January 2021 to help with my setup for Work From Home

I have 2 laptops connected to it on other ports, and the desktop.

I can switch between the laptops without issues. However, when I switch to Desktop port, It seems that I a cannot get the display to come back on, until I reboot the whole server. I tried changing cables between Desktop and KVM, Monitor and KVM, bought brand new DP Cables for everything, yet same issue. I have even went as just booting up to the BIOS. Same thing.

I am not sure what might be the issue. I really want this setup to work so I can switch between the machines without issues. Otherwise, I just wasted money purchasing the KVM.

Any help is greatly appreciated

Welcome to the forums. Sorry to hear you are having difficulties. I’m not an expert, but I do use L1T KVMs and am willing to chat about your issues.

First, I suggest you add tags “kvm” and “helpdesk” to your post, and see if that attracts more interest & assistance. Consider removing the “gpu” tag as I think that tends to reach a different interest group.

Sounds like you’ve put in some effort to try to resolve the problem - well done. DP cables seem to vary widely, and getting “good” cables can be a problem. But this doesn’t “smell” like a cabling problem. (Still, consider saying a little more about the cables you are using.)

I have had good experience with L1T KVMs, but any KVM does seem to make it easier to set up a situation where DisplayPort black-screens. I blame the DisplayPort handshake between monitor & computer, since I have had issues even without a KVM - but it’s hard to be sure.

Your sentence “went as just booting up to” was cut off, but I wonder if you tried just booting to UEFI? I have had very poor experience switching the KVM away from a UEFI display; that’s on my Don’t Do This list.

You don’t mention how long the KVM must be switched away before there is a black screen when switched back. Just a few seconds? Ten minutes or more? I have found that Linux GNOME desktops often get stuck on black screen IF the screen is blanked while the KVM is switched away. To avoid this, I disable screenlock (blank screen), power-saving screen off, and automatic suspend. You might try any similar settings in Unraid (with which I am unfamiliar).

Some other troubleshooting suggestions:

  • Wire one monitor directly to the computer and/or connect keyboard & mouse directly. Does this let you see what’s going on with the monitor that is still connected via KVM?
  • Consider installing another OS (on another drive?) to test the behavior with a different setup, one where you can make changes without affecting your main system.
  • Give us a little bit more of a description of the circumstances that lead to black screen. What’s on the desktop/Unraid screen before you switch away? How long do you switch away? Does it always happen or only sometimes? etc.

Okay, good luck. Here’s hoping you’ll get this resolved soon.

1 Like

This may not be related to the KVM device but may be a Linux issue. Both my Manjaro and previous Debian builds have struggled bringing my display back from a sleep state. Try disabling sleep and see if that improves matters.

As @Caped_Kibitzer says you should eliminate if this is a hardware issue or something to do with the software or firmware. It may be linked to the reset bug that affects NAVI GPUs so consider patching for that.

Also try vnc into the server virtual machine to see if you can force display.

What I’ve noticed particularly with the USB-c KVM is that I sometimes need to reconnect the cable or power-cycle the KVM to get video output back from my pass-through GPU.
Not sure you’ve tried these steps but perhaps they help, even if it’s for a different KVM variant.

A piece of datum: I’m running a KVM (not L1Tech) between a Win 10 laptop and a Win 7 desktop tower. If I’m on the Win 10 machine too long the desktop will go to sleep. Sometimes it takes a while to get the machine back. I believe that the O/S just won’t recognise the KVM on the USB port and won’t wake up. One time it decided to flake off for the weekend and absolutely refused even from a hard reboot leaving me with a dark monitor. I had to replug the monitor and the mouse into the machine, hard reboot, and then replug back into the KVM. It was fine after that. A major pain. I’m not sure this is a help but here it is.

what KVM? I have a IOGear [email protected] 4port USB3.1 KVM and I had to adjust the way it emulates EDID to get it to stay “connected” to some of my equipment.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.