KVM issue with AMD Ryzen 5000/X570 build

I have multiple devices for work and personal use plugged into the 4 port dual display KVM switch (PAAG-E3124A) that I purchased from Level1Techs.

The primary symptom that I’m looking for help with, my main keyboard & mouse functions perfectly fine in Windows. However, during POST, the keyboard never picks up a response to start any BIOS screen (e.g. Enter Setup or Q-Flash). I can start BIOS by using the Windows feature to boot directly to “UEFI Firmware Settings” – the BIOS screen loads, but no input is accepted from the keyboard/mouse. If I plug in another keyboard directly to a front panel USB port, still no response. I have to unplug the cable from the KVM, and plug in another keyboard (in that order) to be able to make any changes in BIOS.

The keyboard and mouse are plugged into standard USB 3.0 ports on the KVM (not HID ports). I plug them in this way to avoid oddities with the advanced features of the Razer input devices:

Razer Mamba Elite
Razer Huntsman Elite

A single USB cable is then plugged into the X570 motherboard. The main components of the build are:

AMD Ryzen 7 5800X
Gigabyte X570 AORUS PRO WIFI

The same KVM setup worked fine with my previous PC build (Intel Core i7-6700K with Gigabyte GA-Z170X-GAMING 6).

I opened a ticket with Gigabyte, and their response :

With different Chipset, the compatibility will not be the same as every chipset behavior to certain controller may vary.
Have you check with the KVM vendor if they had validated their switch on the new AMD X570 chipset boards?

I’m a little doubtful, but I do see oddities from time to time that require a reset of the KVM and attached devices to correct. I recently added an XBOX Series X to the mix, and it works sometimes for supported software (e.g. COD Warzone). But I’ve seen issues where input from the keyboard and mouse doesn’t get picked up at all – especially when the XBOX has resumed from sleep when using the “Instant On” feature. Also noticed that in one title (Forza Horizon 4), no input is possible from any device including the XBOX controller when the KVM USB is plugged in. When I unplug the USB cable to the KVM, everything goes back to normal.

Does this KVM have any firmware updates to address bugs or improve USB compatibility?

I am willing to collect whatever debug information that may be needed for both issues if I can get a little guidance.


I ended up reorganizing how my USB devices were connected to the motherboard, because I was also having issues with device disconnects under load (presumably related to the much discussed AMD X570/Ryzen CPU issues). Change summary:

  1. Moved the KVM and my audio device (GoXLR) from a USB3 to the bank of 4xUSB 2 ports on the rear panel
  2. consolidated a bunch of other devices onto a powered USB3 hub and plugged it into a USB3 port
  3. Moved my RGB devices off of the internal USB2 headers entirely, which were the devices disconnecting under load

No more device disconnects, and as an unexpected side effect, my keyboard/mouse now work as expected during POST and in the BIOS/UEFI screens.

For the record, prior to making the above changes, I had also installed the BIOS update that includes “AMD AGESA ComboV2 PatchA” for my motherboard (F33h) – but that by itself did not help any of my symptoms.

I’m still interested in firmware updates to the KVM, if it exists. As mentioned, I have intermittent issues that require DP unplug/replug or pulling power from the KVM to resolve.

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.