Return to Level1Techs.com

Kdenlive is superior to davinci resolve


#1

I’ve been using kdenlive for a few years now, and it had its share of growing pains. I edit 4k h264+aac 23.98fps video from a GoPro, roughly 60mbps.

Initially, I had 30fps and used proxy clips in Kdenlive to edit this media at a reasonable frame rate. Timeline at 720p for compositing to run at 4k native 30fps. Still, effects would chug it to a crawl and required disabling during playback to get accurate frame timing.

Eventually, a combination of improvements to Kdenlive and changing from 30fps to 23.98fps gave the system a bit more headroom to run composited 4k without too significant of a drop in frame accuracy, and after the 2nd playthrough it will be nearly flawless. Colour grading layers will still cause a 6-10fps drop, but it’s easy to enable/disable on the timeline.

So, after some time, I’ve wondered have I been missing out on a superior experience? Kdenlive doesn’t even use the GPU to accelerate anything. My little 13 minute videos take almost an hour to render - not bad, considering how many layers and composited transitions I’ve used. I’ve got a Threadripper 1900X, 64G, and NVMe storage with Vega 56 graphics. Kdenlive runs great, but what if something else runs better?

So I tried the free version of Davinci Resolve for Linux. No go - it wouldn’t even read the h264 media without transcoding. I run Windows in a VM with its own RX 570 GPU, so I tried Resolve for Windows there. using h264 caused CPU thermal issues, and the GPU didn’t seem to be very utilised.

I bought the Studio version of Resolve 15 for Linux at a whoppin’ CAD$409 and expected it would Just Work the way proprietary software always claims it will. I was able to import h264 media, but… AAC audio does not work on Linux?!

This isn’t a Linux issue, as AAC works great in Kdenlive. This is a Blackmagic Design issue…

No worries. I set up an inotifywatch script that transcodes media I write into an ingest folder on-the-fly, preserving the h264 codec but converting AAC to PCM_S24LE embedded audio. It’s automatic, mostly, and it’s quite neat. I don’t mind this part of things.

Now I’ve got H264 media /and/ audio (though the file is no longer the “original”, but ok) and my GPU is used for processing a 13 minute video in about 4 minutes and 20 seconds. Thermal issues don’t happen like when I ran Resolve for Windows.

However, all is not well. I see the volumeter jumping when audio plays, but no sound comes from headphones/receiver. I’m using Pulseaudio and ALSA with an emu10k1 device, and Resolve 15 claims to support System Audio - no external hardware is required. Still, no devices are listed in the “Audio Output” field. just “Default”, which does nothing.

No worries, however, I set up a resolve.sh script that temporarily places an .asoundrc file in my home directory to point all default ALSA clients toward Pulseaudio, because of another Pulseaudio bug that prevents the emu10k1 from being used as the default device if ALSA is pointing to Pulseaudio. It becomes, as we say, a circular loop. Things hang.

So, I’ve got audio AND video for real now in the Edit tab.

But all is not well. I can’t open the Fusion tab. It crashes Resolve Studio. when I try to re-launch, Studio gets to “Searching for control surface” and then EXITS like a father on his way out for cigarettes, never to return. I have to nuke the contents of /opt/resolve/config and reinstall Davinci Resolve Studio for it to relaunch again. and when it relaunches, most of the configuration is, of course, gone.

No worries, however. I set up a ZFS filesystem just for Resolve so that I can issue a zfs rollback rpool/misc/[email protected] whenever it decided to poop the britches. Now my configuration is embedded permanently here, so I don’t lose it.

Still can’t open the Fusion tab, but hey, at least I can start editing some video.

But all is not well. Every 30-90 seconds I get a “GPU image processing error: -59” message that actually stops playback and interrupts whatever I’m doing - if I’m dragging an element from a bin to the timeline, it goes away. I don’t get my element placed. I have to do it again.

I contacted Resolve support, opened a ticket. Now it’s proprietary support’s time to shine. They will surely solve my issue… oh wait. “ROCm is not a supported OpenCL platform. Please use regular drivers.”

I use an AMD Vega 56. On Linux. What is a “regular driver”? Resolve support gave me instructions to install a Windows driver.

At this point, I requested a refund. I went back to Kdenlive, finished my project, and was super impressed with how stable and fast it actually is. I’ve heard a lot of complaints from Premiere users that I don’t think would apply to Kdenlive. I’ve never used Premiere, so I can’t compare directly.

I’m not doing fancy compositing stuff like some of you - Kdenlive has some OpenCV plugins, and I’ve never really looked at or considered using any of them. Some interesting stuff is there, like facial tracking, but I find myself using other tools to track items in frame.

Anyone used Kdenlive AND Premiere extensively? How does it compare to Premiere? I hear Adobe crashes a lot; can’t say the same about Kdenlive (when GPU use is disabled).


#2

Interesting write-up.

What distro are you on? I’ve had nothing but crashes with kdenlive on fedora last year (using KDE).


#3

Gentoo ~amd64


#4

Ah, that might explain it then.

It might also explain why Resolve isn’t working for you.

I’m having no problems on Fedora with my GoPro footage (after I bought Studio) and I’m having no problems with audio (using pulse) either.


#5

nah, after discussion with BMD support, it comes down to not supporting the ROCm drivers. similarly, their binaries aren’t compiled for Ryzen/Threadripper support. which makes it even funnier, because kdenlive is free software. they charged me in comparison, a lot - and cannot fix it. lovely people though.


#6

Okay, so regarding the ROCm, that makes sense.

Regarding the Zen platform, I’ve got a 1700 and a 1950x. It works great on the 1700 on Windows and the 1950x on Fedora. They used to have a fusion crash around January, but it was patched on Jan 24. GCC compiler flag fixed apparently.

Yeah, they’re pretty cool folks.

They’re trying their best with it, but the hardware moves quick and I don’t think they have the development team to handle all the new stuff coming out. It’s really too bad because ROCm is a great platform. Hopefully that’ll come around soon.


#7

even worse, it’s the only way to use the vega series (10 and 20) on linux.


#8

Yeah, it’s definitely not great, but that’s another reason Nvidia has dominance in the professional field. They’ve provided a consistent ABI for over a decade.


#9

so, I started my testing with a 1060 6GB… wasn’t even detected by Resolve.


#10

Did you have Nvidia and CUDA installed? (obvious question, I know)


#11

yes. I tried everything. I was able to trick it into working once I gave up on the proprietary bits and went for Mesa OpenCL but that crashed pretty quickly. clearly some unsupported bits there.

the whole situation is unfortunate. BMD is not really proactive on this issue.

once I was able to make it work with the Vega and constant GPU image processing errors, even the user interface was clunky and inefficient compared to Kdenlive. I found myself sitting and staring a lot instead of actually working on the project.

want full screen display output? you need an SDI device. kdenlive supports SDI, but it doesn’t shoehorn you into it. what’s funny is I could actually make the monitor fullscreen on 2nd display in the Fairlight tab, but not in the Edit tab. what a stupid decision.


#12

OpenCL isn’t really supported.

I’ve got a 1060 3GB that I’m using as a Linux Host adapter. I can fire up Resolve when I get back to my system and give you some more info about my config if you’d like to troubleshoot it.

Yeah, that’s annoying. I wish they’d allow you to output through a Intensity device (since I have one in my rig)

Yeah, that’s an interesting situation. Why would you need a fullscreen display for audio mastering?


On the plus side, kdenlive is in the process of merging the timeline refactor into master right now. :smiley:

I’ve been waiting on that for a while, since the timeline has always felt really clunky. I hope they can start focusing on feature improvements after that’s done.


#13

yes, they already’ve finished the main merges. the latest release has the refactored UI. I’m a huge fan of auto-splitting audio/video, but it has just a couple quirks I’ve noticed so far to do with moving tracks around - it’s as simple to workaround as ungroup/regroup after moving it, but the space deletion option is less useful now since it won’t work on tracks with a group, which is all of them, by default, now.

and there’s a new feature that was just merged; audio recording in timeline. it’s in for testing as of today.


#14

I haven’t seen this yet. I’m going to have to check it out and try it on my next render project.

If I’m understanding you right, it’s probably the same with Resolve.


#15

most likely. that thing felt hella clunky to use.

example: I clip a track using ctrl+b. probably the wrong key? it selects both pieces afterward. I have to click the timeline to deselect both and then click the track I want to work on next.

kdenlive: I clip a track using shift+R, it selects the right side. I can usually immediately hit del and eliminate just the right half, which is quite handy. I can also ctrl+c|x or other stuff. sometimes I want to operate on the left half, but it’s just a single click.


#16

If you don’t highlight any clips when you’re cutting, you can cut and it doesn’t select anything.

Personally, I don’t have any qualms about the way Resolve functions with the highlighting both though. Works fine for me.

I think that’s definitely a “it’s a feature not a bug” situation.

That seems like a much more sensible action though. I’d probably learn to enjoy this one better.