Issues with sound watching L1T on Floatplane with Ubuntu 18.04


I have encountered an issue with sound when watching videos on Floatplane. My audio seem to enter a sort of error state where sound gets heavily distorted and continues being distorted until a reboot has happened.

The issue has only been observed on Floatplane, YouTube and my local video player is fine.
The issue manifests itself when using the 3 sound interfaces I’ve tested: Bose 700 (bluetooth), onboard audio (aux) and audioengine D1 USB DAC (aux).

The systems are as following:

  • Laptop:
    • Lenovo ThinkPad X230 w/ Intel Core i5-3320M
  • Desktop:
    • MoBo: ASUS Prime Z270-A
    • CPU: Intel Core i7-7700K
    • RAM: 16 GB Corsair Vengence (single DIMM)
    • GPU: ASUS DirectCU II GTX 770

Both running Ubuntu 18.04 with Firefox and both has the issue.

Would anyone happen to have an idea of where and how to start the debug process for this issue?

Have you tried restarting the pulseaudio service?

1 Like

Also what version of Firefox.

I had this issue in ArchLinux and Debian (SID) when I was running Firefox 73 initially. I run the Nightly FireFox builds. It seems to go away on the 3rd to last update of the 73 build. I had no issues with the 74 build and We just got moved to the 75 build last week.

Now I have, it does not seem to solve the issue. Sadly.

I’m running stable and therefore currently Firefox 73.0.
Your questioned made me realize, I had not tried in any browser besides Firefox. I installed Chromium and tried there. The issue does not seem to arise in Chromium. This could indicate that it is Firefox-specific and from your account, it will potentially be fixed in a couple of weeks with Firefox 74.

1 Like

Yeah pretty much. I had reported it and I was not the only one apparently. I think Beta is on 74 currently if you want to try it.

At first I thought the issue was web render as I had turned that on the week before the issue happened but after turning web render off, that did not fix the issue. I then turned web render on and and in the next few days of updates, the issue went away.

In my experience, with all the work that is going on in FF, you tend to benefit better from the Beta branch than stable. Nightly may be a little too much as there is at least one update a day and sometimes you have to revert to the previous update because something seriously broke. Like when they first added Wayland support.

I tried adding the PPA for vnext, but the issue seem to persist in Firefox 74.0b8. I will wait for 75 to hit beta and see if the issue is resolved there. Until then, I will keep Chromium for Floatplane and cry every time I look for the PIP button.

So FP can’t be viewed with vlc?

I’m uncertain what you are suggesting here.

If you are thinking of downloading the video and playing it locally, I have been doing so, although with GNOME Videos, but this creates a whole new set of issues.
If you’re suggesting that Firefox is using a VLC-related library for video playback, then I can confirm that VLC plays the downloaded videos just fine.

I suggest nothing. I am asking only out of curiosity. :wink:

Since you are using Chromium for FP, I thought about vlc in a similar way as I use on my tablet to watch youtube. Newpipe as a content viewer, but video playback just on vlc with live stream without any previous download.

And I asked because I don’t have FP and I’m wondering if they are using some more sophisticated ways of providing a data stream that could cause problems to play a stream data in vlc in the same way as you can with YT. :wink:
And instead of using a second browser specifically for FP, still use FF as a content navigator for FP and leave video playback for vlc. Although this is obviously no solution to the original problem, it’s just a loose thinking. :wink:

Been watching FP on FF for 7-8 months.

I run fedora tho.

I don’t have any audio/playback issues.


Videos download as mp4 from FP.

what resolutions have you tried

Interesting, but I believe VLC should somehow receive a session cookie from Firefox or authenticate itself and I am not sure that is possible.

Is Fedora using a different audio stack than Ubuntu? Because then maybe it is a Ubuntu-Firefox-specific issue then.

All of them besides 4K.

if i lsmod

the snd line:

snd 98304 21 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm

It also occurred to me, for this I had such a question. :wink:

Maybe try with codecs … Occasionally on YT I have problems with audio synchronization with saved streams that were live. For some reason, sometimes YT when forcing VP9 / opus sound does not always have good synchronization, but it is enough to block and allow only h264 (avc / opus) and audio is ok. I don’t know what combination of video / audio FP uses but maybe try something similar. Unfortunately, enhanced-h264ify will only work with YT.

This would be mine and I honestly cannot tell if the difference means anything.

snd                    86016  38 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi

Gee, I’m not that knowledgeable about the Floatplane format. Unlike YouTube, I do not think they run a separate video and audio stream which is then mixed on playback. If this is true, I am not sure you can choose audio codecs.

Just a quick update. Now 1½ years later, running Ubuntu 20.04, I still had the same issue until recently as I replaced PulseAudio with PipeWire and my issues are gone.

I followed this method: bluetooth - Replacing Pulseaudio with Pipewire in Ubuntu 20.04 - Ask Ubuntu


I am glad that you were able to fix the issue. I wonder what setting in pipewire fixed the issue. I wonder if it was a sampling issue.