Issues with Broadcom Wi-Fi Drivers - Sabayon Linux

So I've been distro hopping alot as of late, I jumped from Ubuntu, to Tumbleweed (which was just broken entirely) to Manjaro (which worked perfectly) to Sabayon Gnome..

Sabayon so far is nice. everything seems to be working. but the unholy abomination that is the Broadcom Wi-Fi drivers. now the issue that arises is, My Laptop doesn't have an Ethernet port. so I've basically hit a wall. I can't use the Command line to install my drivers.

Anyone got an idea on how to get this shit working? the amount of stupid that comes with working with Linux is too high.

If it helps my Network Controller is a Broadcom BCM43142 (Rev. 01)

I had issues with these drivers in fedora 22 - I eventually fixed it by connecting my phone via usb as an ethernet device, and downloading bcm43xx-fwcutter then after a reboot and a system update the driver worked, but I could see everyones network but my own - problem here was that the driver only scans wifi channels 1 - 11 and my router was broadcasting on CH 13 - so watch for that too. Took forever to work out.

have a read through this as well

Also read this because im retarded and gave you the wiki for Arch not Sabayon :/

Honesty, get another wireless card if you can :) there are certain Broadcom that just will never be happy with the proprietary or open source drivers (in my experience)

Not sure if I have used the one you have there, but at least 2 different Broadom cards in HP laptops (using same drivers) worked most of the time but kept letting me down at bad times, like they could not deal with marginal conditions or something.

BIOS restrictions could be a problem when changing wireless cards, but often eBay has a good selection. You could even download the service manual and seek a spare, sometimes a model will have choices in wireless cards, hopefully something Atheros or Intel which is what I have most success with.

1 Like

Same experience here with a Dell D420 (extremely old Core Duo laptop). Any ubuntu based distro would just not install bcm or broadcom-wl. I don't know which is opensource and which is stable but tbh I'd use any driver as long as it works.

Browsing the bugs.launchpad and ubuntuforums I found out that many people downgraded their drivers to work with the updated kernel (the source of all misery apparently). src :

Condoleances for not having ethernet. You might in the end have to install bcm-fwcutter (firmware dearchiver) and bcm-kernel-source (the open source drivers for all broadcom boards) from the CLI. In that case good luck and may you have a better experience than me (I wasted 4 hours and no tangible result other than a ruined Xubuntu install).

In the end I installed Manjaro and it works just fine with the proprietary driver out of the box.
informative link:

Yeah but is ~15$ plus some shipping cost worth the effort? Add a little more and you get a (probably, most good laptops should have ethernet) better laptop like a thinkpad or a used more recent dell.

The thing with Sabayon is that the performance is like water. Smooth as hell. I'm going to tinker with it again this afternoon to see if i get it working everything is great and works. with the exception of the Broadcom Chip.

edit: I'm just going to distro hop. fuck it. this is too tedious. the documentation is outdated on Gentoo.