Issues with Audio on Manjaro with KDE

I’m having a really bad time trying to figure out this issue on Manjaro with KDE Plasma. I’ve been a long time user of using Manjaro Linux, which I’ve been using over the last few years or so, but I was previously running on Cinnamon Desktop and decided to make a switch to using KDE Plasma on my main desktop rig after using it for quite some time on my laptop, so I pretty much prepped my system by installing KDE Plasma and all it’s relative packages, then go to make a switch over to by logging out and of course selecting Plasma (X11) from the login screen after installing everything as needed.

So I was checking to make sure that all my audio configurations were still working the same way I had them setup on Cinnamon Desktop, and thats when I began to notice some annoying issues. My keyboard has a knob for changing either Audio or RGB lighting on the keyboard, by default I have it set to Audio control. I have the Roccat Vulcan 121 AIMO keyboard, and it’s been working perfectly fine when running on Cinnamon Desktop, which I also use with program called Eruption which gives me RGB control of the keyboard for Roccat Vulcan series keyboards, but in KDE Plasma, the knob for controlling the audio wouldn’t function at all. It’ll show me the volume level the computer is currently set at, as indicated by the RGB lighting on the keyboard when I turn it, but it doesn’t go up or down. So I take a look into my Audio settings from the Taskbar and for some reason it shows the Audio Devices as blank, like it just says No Output or Input devices found but if I open up KMixer the devices DO in fact show up, and Audio can be played out of them as normal. I opened up Pavucontrol and it also shows them displayed there, and I can also change the output sources there and audio plays just fine, input sources work fine also.

I tried closing out KMixer to see if that fixed the issue, but it did not. Pulseaudio doesn’t appear to be interfering with anything either. All devices shows as they should, and audio can be played to outputs, but still don’t show in Audio Volume, and still can’t control the audio from the knob on the keyboard. I also found I can’t control audio level using my mouse or headset either. – The mouse is also a Roccat brand, the KONE AIMO, I can normally hold one of the side buttons on the mouse and scroll with the mouse wheel to adjust the audio, but that wasn’t working at all like it would when I was on Cinnamon. My headset which is a Logitech G663, which has its own audio knob on it, normally when I adjust on the headset, it also adjusts the audio level being output from my PC which can independently control the audio, at least thats how it should work, but is not the case when I switched over to KDE Plasma.

I do not know how or why the audio configuration doesn’t work the same as it did when I was using Cinnamon, or why the devices appear missing from the audio panel, it honestly makes me just want to jump back to using Cinnamon if it’s just going to be an issue like this if I can’t figure out how to fix this and make everything work as it should. To me it looks like all the media keys are just simply not working, because not even the Fn keys are working when pressed, the top row keys for F9-F12 are all media keys which aren’t being read as inputs

I know this is already bit of a long post, but how can I fix this so it works properly? and is there some way I can just get the audio manager to just use Pulseaudio instead of KMixer and that other audio panel? Because things worked fine when it was just PulseAudio and all Fn keys functioned as they’re suppose to.

You could try killing pulseaudio and then running in verbose mode it might help diagnose?
pulseaudio -v

more stuff on the arch wiki:

Im not sure if thats what your looking for but the verbose mode output might give hints