Issues with ASRock H77 RAM Configuration

I have tried 5 different DIMMs, 


2x4gb Gskill RIP Jaws 1600mhz

1x8gb PNY XLR8 1600mhz

2x4gb Corsair Vengence 1600mhz


I am using an ASrock h77m-itx mobo, with a i7-2600k, corsair hx750 and the RAM listed above


the mobo has 2 Memory Lanes, I am using the second instead of the first. Out of those 5 DIMMs only 1 DIMM worked, I am using 1 of the 2 corsair vengence 4gb. The other 4 DIMMs did not work on either Memory Channel. I have tried cleaning the RAM, buying new RAM (the 8gb PNY XLR8) I have also used compressed air and cleaned out the Memory Channels. I have tried updating the bios, clearing the CMOS multiple Times Not quite sure what else to do, and I cant really afford to RMA, I work from Home and need my computer, additionally shipping to CA from MA would cost about 1/3 of a new one. 

you also try every dimm seperatly in one slot that worked?

Just to determine, if it the dimms that are not working, or the ram slots.

Ensure that the socket on the motherboard isn't damaged. A lot of these issues are attributed to a damaged CPU socket, which causes the onboard memory controller to malfunction.