Issue installing Freenas onto a Dell T1600

Hi All,

I was wondering if anyone can help me in with this. I've managed to get my hands on an old Dell T1600 that I was planning to run as my nas. Basically I've been unable to install Freenas onto a Kingston 120GB SSD. I've tried using a USB to boot the device and via DVD and run into the same issue every time. I get to the Console Setup screen and am given the option of !. Install /upgrade, 2. Shell, 3. Reboot, 4 Shutdown System. Once I'm here and select option 1 the machine just locks up completely. I've left it for around half an hour and when I've come back and shutdown the machine via the button on the machine, the shell pops up with all of the saying "up time is zxy" and goes through the rest of the shutdown procedure.

Before I started on this project I installed Freenas on a VM just so I could get an understanding and first hand experience and did not run into this issue at all. My troubleshooting so far is to format the SSD through my main machine and try to reinstall the OS. After that failed I formatted the drive again and install Windows Server 2012 R2 to see if that would work and it did. I'm not too familiar with Linux at all so I am not sure why it locks up during the installation as the machine is a pretty "decent" spec.

Specs for the 1600 are:

  • Quad core Intel Xeon e3 1200 roughly 3.5Ghz (Can't remember the exact model)
  • 16GB of Kingston ECC RAM (2x8GB DIMM's)
  • 1x 120GB SSD
  • 2x 3TB HGST hard drives

Sorry for the long paragraphs and thanks in advance for your help.



1 Like

Try to install a different OS (probably a linux distro). Just to see if an incompatibility with FREENAS.

I've tried installing Windows Server 2012R2. I'll give Fedora 25 Workstation a go later and let you know.

It honestly just seems to be another case of FreeBSD's lackluster hardware support. If you want ZFS try going with OpenIndiana (a free Illumos distro) or a Linux distro.

Edit: s/Solaris/Illumos/g

The freenas install shouldn't take that long. It's not exactly big.

What you should be doing though is installing it to a quality USB drive, preferably two (so it mirrors). You would then boot off of this. That being the case you could install it to a USB drive on a second machine (assuming you have one) and then try booting the Dell off of that. You would then use the SSD as a cache drive rather than an OS/boot disk.

Freenas uses freebsd as it's OS, so it is not Linux. FreeBSD is way more up to date than Open Indiana which has stagnated for years. If you can't get freenas to work you could try SmartOS which is also based off of the illumous kernel and has ZFS, KVM, etc. support, but is designed more for running VM's and containers rather than being used as a NAS.

EDIT: you could of course set up ZFS on Linux, or go with ReFS on your Windows Server 2012 R2.

Hi Everyone,

Sorry for the late reply. I’ll be honest I’ve given up trying to get Freenas to work on the 1600. I’m going to be building a custom NAS shortly and I’ll be scraping this machine into an ESXI host for me to play around with.

Thanks for all your help.