Return to Level1Techs.com

Is my PSU dead? :(


#21

So another update on my rig: After it was working for awhile I went to move it over on my desk a little and I did so by putting my hand under the case right under where the psu is and it shut off again and did that thing where it’ll turn on then back off right away (yeah I know I probably should move the system while it’s on). So I thought maybe one of the wires was loose. So eliminate variables I pulled the psu out of the case and I’m running it outside the case. I made sure all the plugs were seated firmly. And it worked. I tried shaking the cables, shaking the psu, tapping on the psu etc to test for anything loose. I tried smelling it for that foul chemical smell of burnt electronics. I looked at as many of the electrolytic capacitors as I could to see if any were bulging. The caps that I could see are fine and all the shaking and tapping did nothing, it stayed on just fine in windows while shaking / tapping the psu and cables. So I don’t know if it could be a loose connection.

So I tried to load the psu as much as I could and so I launched Prime95 and Unigen Heaven at the same time. Which according to Corsair Link only brought the psu up to like 300W load so either way it’s not like the psu is being stressed. Also my CPU was not OCed for this. Only OC was the GPU.

Well after running both stress tests at the same time for a little over 20 minutes I gave the PSU a light tap and it shut off again. And would only turn on for a split second before shutting off, the usual it’s been doing. Then I also noticed the little test light on the psu was solid red which in the manual means the psu isn’t happy. After letting it sit for about 10 minutes again it’s working for now (using my rig to type this) but I’m leery of using my desktop right now as I don’t want to harm my components by constantly having the power cut to it. I’m thinking I’ll open a support ticket with Corsair to RMA the psu.


#22

Ahh. Sounds like a loose connection or cold solder. Definitely RMA it.


#23

Could be the internal fuse beeing blown.

And this


#24

I grind through PSUs somehow. I have gone through 3 PSUs in 4 years.


#25

Probably the PSU, but also try a different AC power cord.
They can break internally leading to an intermittent connection.


#26

If you have a bad time with PSUs breaking all the time, it could be that you’ve got bad electricity in your home. Any other doodads break in your house recently?

If you do have to RMA the PSU, investing in a transient/surge protector (voltage suppressor) could be a good choice to prevent future failures. Typically not as cheap as a regular PDU, but a worthwhile investment. Especially if your outlets are not connected to ground (for your own safety ; ).


#27

Nothing else that uses electricity has broken here. Idk if I have another AC cord to try but I can try that.


#28

What is the power supply? if there is NO dust then the power supply over heated, if it is has a fan stop thing the temperature sensor might have killed it, being reporting too low. rest cmos, buy a cheapish power supply and use it for testing. If it doesnt post then it is a bad board. Hope this helps. And sorry for having your rig down. I understand it very much blows.


#29

Really, that sounds like voltage from the wall.


#30

random effects like tapping hitting a bump etc… always always always in my experience is a bad ground.


#31

So an update on what’s going on. I think the digital box that connects the psu to the mobo via a USB header to allow Corsair Link to monitor what the psu is doing might be shorting out / bad. I tried using my desktop yesterday without the box plugged into the psu (but still into the mobo) and after about half an hour or so it shutoff and wouldn’t turn back on. However after unplugging the box completely from the system it ran for over 8 hours all day with no issue. I’m trying it now with the box plugged back in to see if the problem pops back up again. What lead me to thinking it might be something with the digital circuitry in the PSU is that Corsair Link often says the PSU output is 0W on the 12V, 5V, and 3.31V outputs. Idk if the the 5V or 3.3V should say anything but I know the 12V should be saying something and the overall output shouldn’t be 0W unless my system doesn’t follow the laws of physics and my rig can do it’s thing without consuming power lol :smile: (which would be awesome if that was true haha).

Another thing I noticed. My psu has a built in test function where I push a button on it and it should turn on if it’s working right and the test led should light up green. When my system shuts off the test led is red which indicates a problem. I can immediately make the PSU function again if I unplug the 24pin connector from the PSU. And I literally meaning from the PSU. If I unplug the 24pin from the mobo it seems to do nothing and the test function doesn’t work unless I have it unplugged on the PSU end of the cable. Which I find strange that it matters which end of the 24pin cable I unplug.


#32

Here are two screenshots of what Corsair Link shows. One where it is reporting the power out and one where it isn’t. Either way the power graphs are very abnormal.


#33

which means the connector in the psu the 24 pin cable goes into is faulty. RMA it.


#34

Yeah I submitted a ticket with Corsair but they didn’t get back to me on Friday about it so I gotta wait till Monday. I’ve just been trying to narrow the problem down and I think it’s narrowed down to either something to do with the 24pin connector on the psu end and / or the Corsair Link digital box.


#35

Oddly enough today I have yet to be able to replicate the problem. I’m running stock clocks on my CPU but the other day I was able to replicate the problem on stock and OCed settings so I don’t think it was OC related.


#36

Since it seems like the RMA with Corsair is going slowly (they responded to my ticket about a week ago asking for the invoice from when I got the psu and I uploaded it a couple days later and have yet to receive a response) I got a new Seasonic psu and so far everything is working great. I’m wondering is Corsair going downhill? They’ve always replied to my support tickets very fast (within a day or two). And also looking at the newegg page for the AX1200i psu it doesn’t look like it’s that well received. Only 3 eggs and a lot of people complaining of slow RMA and that PSU dying within 2 to 3 years. Mine is 1.5 years old that I got from RMAing my original AX1200. I wonder could the what seems to be poorer quality of the AX1200i be that Corsair switched OEMs for that PSU? When googling it Seasonic was the OEM for almost all higher end Corsair PSUs but all the i PSUs are made by Flextronics. My original AX1200 (yes the non i one) lasted a bit over 3 years and the only reason I RMAed it was because the fan bearing was going bad and it was starting to make coil whine but other than that it functioned fine (I figured out my shutting off problems then were due to the bios which went away with an update). But now my AX1200i didn’t even last half as long as my AX1200.

Anyways my PC seems to run quieter with the new Seasonic 850W psu which is strange since both power supplies usually run with the fan off.


#37

This could be correct, Toms hardware had an article about psu’s and what boards they have inside.
You are probablly able to find it wenn googling.
If i remember correctlly the i and non i psu’s from Corsair have different brands boards inside yep.

I´m personally not a huge fan of Corsair psu’s all that much.
They are a bit overpriced sometimes because they have the Corsair brand on it.


#38

So op, did Corsair RMA go through?

And yes, can’t go wrong with seasonic.


#39

Seriously. Asked if they could just send me the replacement 140mm fan for my PSU because I got sick of hearing the sound of mice living in my computer; they told me no, because warranty sticker… Sure, let me just send you a 10lb brick across the map for a stinkin 2pin fan.
Shit, I mean, even Dell would have been cool with it.


#40

if you suspect your psu is shot get one of these. I keep one around the house at all times.