Return to Level1Techs.com

Is my PSU dead? :(


#1

So I’m wondering if my psu is bad. Yesterday I was working on stability testing my cpu and the system just abruptly shut off and would not turn back on. If I flipped the PSU switch off and left it off for a few seconds then flipped it back on and pressed the power button my rig would turn on the immediately shut off. I kind of panicked and thought I fried my cpu but my vcore is at a conservative setting of less than 1.3V. I tried the trick of shorting two of the pins on the 24pin connector and the psu turned on and stayed on. So I thought it was ok. Plugged the 24pin connector back to my mobo and tried to power on and it turned on (didn’t post because I had the cpu power pulled and no ram). Put everything else back in and it posted and booted just fine. Had no issues for the rest of the night. Well now today I’m having the same issue. It started with a few BSODs and shutting off but allowing me to power back up so just to be safe and eliminate variables I tried setting all my clock speeds back to stock but before I could do that it shutoff again and will not power on. I even tried shorting out the 2 pins on the 24pin connector and the PSU flicks on then immediately off.

Anyways any help would be much appreciated and I’m hoping I didn’t kill my cpu… (I did try powering it without the cpu power again to see if it would try to post and fail but it still immediately shuts off).

System specs:
i7 8700k @4.9GHz with about 1.285V vcore
16Gb G.Skill Trident Z ram @ 3000MHz
Asus Maximus X Hero mobo
Asus Strix GTX 1070 Ti
Corsair H100i V2 AIO
Corsair AX1200i psu

What’s puzzling me is how I could have killed the PSU as it’s less than 2 years old and it’s WAY overkill for my system, however I did get it by RMAing my old original AX1200 to Corsair. My system draw in Corsair link is usually less than 400W. I know it isn’t filled with dust because the psu dust filter is practically spotless.

Anyways I’d appreciate any info and hopefully I didn’t kill my CPU as that would be much more pricey and a hassle to replace. Thanks!

EDIT: I don’t know if this means anything but after I got it to power on and stay on last night i was monitoring power draw / delivery in Corsair link and every so often it would say 0W output then go back up to it’s normal idle output.


#2

Did you reset your CMOS? If not, do that.

My guess is your CPU needs more voltage. That looks like what can happen when your overclock fails.


#3

Yes the first time I had the issue my first thought was to reset CMOS and it didn’t do anything. My current 4.9GHz profile is Windows stable and mostly stable for games with the occasional crash. I was just trying to get it real nice and stable. But I’ve gamed for hours before and it might BSOD like once.


#4

It should never, ever, BSOD. I would still try giving the CPU more voltage and playing with LLC too.

If you can’t POST at all, then you’ll need to start replacing hardware one by one until it does, to narrow it down.


#5

First thing i would do is reset cmos by unplug it from wall power,
and then take out bios battery for a few minutes.
Then it should be totally resetted, then in the bios set date and time,
but dont toutch any overclocking settings and just do some test runs on stock speeds.


#6

Power supplies die all the time. In my experience, it’s in the top 3 reasons for a system to be offline.
Mechanical hard drives
Power Supply
Memory
are my top 3 offenders. Mechanical drives usually wear out a couple blocks that are occupied by swap files. Memory sometimes goes bad. Power supplies fail all the time. Even nice ones. Yours has a 10 year warranty.

Some troubleshooting tips:

Unplug all drives from system and see if it powers on. Unplug all USB except mouse and kb if you use them.

Your overclock can’t be ruled out, so reset BIOS. Also if you applied a recent BIOS/UEFI/Firmware update, you might have the shitty microcode Intel released. You might have to revert to an older BIOS. Regardless, a memory test should be run too. I recommend memtest86+

You can do the PCI(e) card rain dance: remove all cards, power cycle (without cards ), reinsert cards


#7

PSUs can totally die, but usually if they last through the first couple of months they will outlast the sun, moon, and stars too, until their fans die of course. Same with CPUs and memory, they last forever. I mean, it’s possible.

Mechanical drives definitely die, moving parts. I’ve had motherboards die too, usually because I messed up and shorted a contact because I didn’t mount them properly in my youth.

Since he said he always got BSODs my guess is his rig was never stable and it just got worse due to cooling degrading. But if it won’t POST at all, even after resetting the CMOS, it could well be any of the above.


#8

Okay I will try you suggestions in a little while I gotta work on some homework from uni. Is my CPU likely okay though(like physically not necessarily OC stable)? I figured since mobo power and cpu power is disconnected and I’m attempting to turn the psu on with the paperclip trick and it still shuts off immediately with it disconnected from the mobo and cpu.


#9

With the described behaviour, this is very likely the case.
Followed by dying mainboard or PSU.


#10

Yeah I’ve been watching the whole meltdown / spectre thing and I decided to wait a little while before flashing my bios to let the update be fleshed out. So my bios revision is the one just before the bug fix release.


#11

Buy a PSU at a local big box store - someplace that will allow returns - and see if that does it.
It’s better to know for sure what the problem is before going through all the RMA hassle for your frankly extreme power supply.


#12

Oh also I’m decently familiar with working with electronics so if anyone knows of ways I can use my multimeter to probe my psu and test it I can do that as well to diagnose it and see if it’s the culprit.


#13

Can check if all of these are present:


#14

Basiclly if you take a paperclip and connect the green wire with a black wire on the 24pin power connector, the psu should turn on an stay on as long as the paperclip sits between those two pins.
If the psu switches on and directlly off again, then its allmost certain to say that there is an issue with it.


#15

Yeah that’s what I tried. I have mobo / cpu / gpu all unplugged from the PSU. Only things that are plugged in is the RGB light hub for my fans, a HDD, and a SSD. I’ll try unplugging more of those and see what happens. But trying that paperclip trick it’ll switch on and light my fans up for a split second then immediately shuts off.


#16

Ahh. Maybe a short? Were you down a screw at any point in building the thing, perhaps?


#17

Then my guess is that the psu is the cullprit.
If it still switches on and off without anything attatched to it.


#18

PSU is toast.

Hopefully Corsair’s RMA process is better than EVGAs. Holy shit that was bad.


#19

This PSU I got in an RMA from the first AX1200 that I had. That PSU was like 4 years old and was having some nasty coil whine and the fan bearing was going out and Corsair replaced it no questions asked and I got the AX1200i from them in the mail like 3 or 4 days after I mailed off my original PSU so it went smoothly. In a bit I will try unplugging everything except my fans from the PSU (literally from the psu since it’s modular), so the least amount of things are connected and I’ll report back what it does.

Also it was like a downhill slope with my PSU tonight. When it shut itself off the first time it came back on for a few minutes then shutoff. Then back on for like a minute before shutting off. And now it instantly shuts off. I would think if something outside the PSU is shorting it out it wouldn’t have had a decline like that but I’ll check everything.


#20

Okay I think my rig is seriously being a major troll right now. After letting it just sit for a little over an hour while doing my homework it’s working “fine” right now. The PSU finally turned on with the paperclip trick so I plugged everything back in and it powered on, POSTed, and booted into windows. I’m actually using it to type this right now. I have reset my CPU back to stock speeds with my RAM at it’s default XMP profile. Right now I am unsure of what the issue is. The only thing that’s different is I have the back panel removed (it’s a glass panel).

EDIT: When I did try to power it on when I got everything connected back up it did shutoff after a second or two then switched back on and started to POST, like when apply certain changes in the bios it seems to power cycle itself before attempting to POST.