IP KVM Hardware Alternative to Supermicro Java based iKVM?

I have a Supermicro Motherboard with the Java Based iKVM. It has not worked in browser for a long time now for obvious reasons. I am basically stuck with IPMI View which isn’t Linux friendly and I would like to avoid using it just for 1 device anyways. I would like to use either a Web Browser or RDP. What options do I have other than buying a new Motherboard, CPU, and RAM? The newer boards iKVM is html 5 based.

I was thinking an IP KVM. What is out there that is for a single VGA device and not overpriced? I only need like 4 fps. Be able to force reboot, send ctrl+alt+del, and support Keyboard. I don’t even need mouse support.

When I looked into this, no one had reverse-engineered IPMI enough to tap into it without the provided tools.

I run the web applet with javaws or use ipmiview. Firefox has better support for the older ipmi web interfaces. Some of them I can’t even log into anymore with chromium browsers.

How so? It’s a Java app so it’ll run on anything.

The WebUI for the IPMI works fine in FireFox and Brave. I even get the preview image for the iKVM but can’t launch the jnlp (Java Web Start) file to view the video. I remember a while ago once you closed the ‘you need java’ popup the IPMI would log you out but that doesn’t seem to be the case now.

The problem is launching the jnlp file that gets downloaded. It seems like there are involved methods of getting it working but I want to avoid that.


I said “Isn’t linux friendly”, not that it doesn’t work at all. If you can get it to work let me know how you did it because I can’t seem to get it to.

Annoying… I can’t post links. Serve the Home has a guide on installing IPMI View on debian and it involves compiling and all this other nonsense. I would like to be able to re-install fresh without having to do all this random BS just to get a stupid iKVM to work. Which is why I would like to access it via WebUI or RDP.


sudo apt install icedtea-netx

It is also in the Pop!_Shop on Pop_OS

Go to IPMI in browser > click cancel on the ‘need java’ popup > click on the remote console > open the jnlp file with IcedTea.

This will hold me over until I upgrade to threadripper. I can finally uninstall IPMI View off my gaming PC.

Not necessary. Install jre8-openjdk IIRC and you should be able to run it.

Yep. In cli, the command is javaws followed by path to the jnlp file.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.