Return to Level1Techs.com

IOC Fault when importing pool (mps_reinit, HBA LSI Card, Freenas) [Solved (sorta)]

Hi,

i need help :cry:
i upgraded my NAS with a new board ( Supermicro M11SDV-4C-LN4F) and reinstalled freenas.
Everything without my disks attached to the HBA card.
After installation i attached my drives to the HBA card, (re)booted, and wanted to import the pool.
The import seems to be stuck in an infinite loop of trying to initialise something from the LSI card (see picture).


The card worked fine in the other systems and basically all i did was change the motherboard (CPU, RAM) and reinstall everything.
Does anyone know what this is about?

I have this lsi card:

One time when i booted this came, but after hitting a key everything booted fine:

i do not know if this helps, but here it is:

Thank you!

Try reseating the card and cables.

1 Like

thank you for you answer!

unfortunately i tried that already :confused:

You mention you reinstalled freenas. Do you have a copy of the original install so you can go back?

Worth checking it’s not some unrelated problem with one of the disks from the move.

Do you have a spare single disk to try connecting to the controller to test it is working with the hardware.

No i don’t have the old installation anymore. I used the same usb-sticks. Also it would have been an installation to another hardware.

But I haven’t thought of trying to create a new pool with a spare disk, thank you!
So i just tested this - unfortunately same thing :confused:
It is not just the import.

The disks are listed in the freenas GUI. It seems this occurs when it is trying to actually use the disks…

The “IOC Fault” message is the result of errors on the controller reported by its firmware. Unfortunately I don’t know of a reference to interpret what “0x2622” means, it’s a firmware-specific error code.

You may try re-flashing the adapter firmware.

FreeNAS and BSD in general is highly tolerant of hardware. Changes. My build has survived 3 migrations without reinstall.

Your problem sounds like an adapter issue. Consider swapping the controller. Test the disk in the onboard sata ports if you can to make sure it’s not the motherboard or a build issue.

@freqlabs @Airstripone thank you both for time and help so far!

Good to know that freenas is that good at hardware migrations. Next time i will surely go that route :smiley:

I also think it has to be a controller issue. I tried to create a pool on a spare disk when directly using a SATA port on the MB -> No issues.

I also tried another LSI card i have that is also one of those ebay flashed to IT Mode ones. Same issue!
But the LSI card works fine in my other NAS which still uses an old Xeon.

I orderd one a “simple” pci to sata expansion card and will see if it works with one of those.
If it works with those then it is the combination of such LSI cards with this board i would say, because the card works with an other board fine…
If it does not work then it has to be the PCI Slot i guess.

Let’s just hope it is not the board :crossed_fingers:

Update:
I wanted to see if it is Freenas (drivers, firmware, sth missing with it i mean).
So i installed ubuntu on a spare disk and tried importing and using the zpool via ubuntu over the LSI card -> works like a charm.
So it has to do something with (vanilla-)freenas installation not liking the LSIcard/MB combination.

Will post updates and potential solution if i find one :slight_smile:

My current solution, which i’m going with, is a different card, a simple pcie sata extender card.
So 3 of my 6 disks are now directly using MB Sata ports and the other 3 are using the extender card. And that works with Freenas. So i’m sticking with that.

Unfortunately i still don’t know what really is causing the problem.
But i’m thinking Freenas does not like the MB/card combination. My main reason to think that is, that it works fine with ubuntu server

So problem solved i guess :expressionless: