Return to Level1Techs.com

Installing openSUSE Leap 15.2 and Hardware Bugs

I am going crazy right now, trying to install openSUSE Leap 15.2;

However I cannot boot into the installer, being flooded with errors caused by the 17h PCIe GPP Bridge of my Gigabyte X399 Designare Ex motherboard before the screen output becomes corrupted and the system seems to be hanging.

I am running the most current version of the UFEFI (f12)

Maybe anyone else has the same board so I can validate if its that or something else that prevents me from booting into the installer?

15.1 runs just fine.

The issues don’t seem to be related to the aspm bug (which on Gigabytes F12 UEFI is definitely still there), but instead somehow related to my RTX 2070, I think.

On 15.1. I can install fine and on reboot I get the same error, but I can ssh in and install the drivers (if I deactivate secure boot, enable SSH during installation and not when using an encrypted LVM drive)

Sadly I don’t have any other GPU to test with, otherwise I’d try installing with an AMD card and install the NVIDIA driver.

Have you tried using the nomodeset kernel parameter?

Thank you, that fixed it. No idea why I didn’t think about it.