Installing Linux on 2009 iMac, black screen after bootloader

Hey Guys,

So i recently got my hands on a 27 inch late 2009 iMac. I replaced the hard drive with a formatted one and loaded Kubuntu 16.10 onto a USB drive and booted the thing. The bootloader came up fine and i chose the default option of "start Kubuntu". Immediately after the screen turned off but the computer kept running. I repeated this 2 more times with the same results. Anyone have any clue whats going on? i see a brief flash of about 4 lines of shell text too read immediately after selecting start Kubuntu then the screen just dies. Anyone else run into issues putting Linux onto an iMac?

This is a simple fix

Here's what you need to do when booting the mac to get your video output workng:

  1. Choose the EFI Boot option from the startup screen and press Return.
    • You will see a black and white screen with options to Try Ubuntu and Install Ubuntu. Don't choose either yet, press "e" to edit the boot entry.
  2. Edit the line that begins with Linux and place the word "nomodeset" after "quiet splash".
    • The whole line should read: (Or something thereabouts
      "linux /casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash nomodeset --.
  3. Press F10 to boot.
  4. Now install ubuntu as normal
1 Like

Worked like a charm, installing away. I owe you a beer.

Edit: Well it worked to install Kubuntu but after rebooting im getting the black screen again. Not showing the bootloader at start up either.

Do the same thing to the installed grub bootloader. Just press up-down arrows and escape quickly at startup it should show up.

I'm guessing you have a iMac with a nvidia GPU?

It fought me trying to get into Grub but i added the nomodeset option and booted, now theres some very odd screen tearing, basically the screen looks like its 800x600 and repeated several times across the top end of the display. Tech Specs at Apple say its running ATI 4000 series internal graphics. I'll mess around see if i can set the resolution right. Might just need to use the ATI proprietary drivers to get it running.

Think this fight would be easier if i were using 14 or 12 instead of 16.10?

I'm not sure the older distros would change it. I haven't ever tried.

I'm just running arch on my old iMac, but that's not easy to install, because it's arch.

Yeah i'm not quite ready to level up to arch at this point, plus if i do get this working it will probably be given away to a much less savvy user, so that disqualifies Arch as well. I've been trying to boot off a USB stick again, but holding Option while booting just displays a white screen with a cursor, no startup manager. I'm really reaffirming my hatred for Apple-crap.

This isn't an apple crap issue. Plenty of people have put linux on their 2009 imacs. We just need to figure out whats going on.

If anything I am willing to be that this is a graphics driver issue.

Yeah installing 16.10 pops up an error momentarily showing "no UMS support in Radeon module." which is probably why the installed system looked all wonky, but the installer looks fine.

Edit: also i stick by the term Apple-crap. This thing has the GPU exhaust blowing across power supply, and the main ATX power cable sits right beneath the WiFi module. I know DC doesn't put out nearly as much EMI as AC does but it's still gonna affect the signal. Also, there's no motherfucking eject button on the CD drive. There's not even a hole to put a paperclip in to force eject a CD. What kinda Fucocked up bullshit is it sacrifice a tiny pinhole to preserve aesthetics?! /rant


2009 was apples worst year IMO. Everything 2008/2009 from apple breaks.

That isn't a fix. Its a workaround by disabling the GPU. Just try watching an HD video in full screen mode. It will give you a still frame.

Does anyone know a real fix, that doesn't cripple my iMac?

This is a common issue a lot of people have.

You can follow this guide:

Afterwards install the newest nvidia drivers.
You can use this repo for that:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update && sudo apt install nvidia-381

#Re-install lightdm
sudo apt-get install lightdm
#choose lightdm as the default when prompted.

If that doesn't fix it, the issue may require more work and research on your part. Or it might be unsupported.

SecureBoot on your mac may also prevent you from successfully running ubuntu + nvidia drivers.

This is a possible outcome with some variations of iMacs

PS: Message tone is important if you want anyone to help you

That's very interesting, but the 2009 iMacs have ATI graphics. (ATI Radeon HD 4670 256 MB) Later models have nvidia

I found out there is a problem with support for older series AMD gpus in the latest linux kernel. I installed Kubuntu 14.04 and haven't encountered any problems since.