Installed a new R9 280, Now no POST *Please Help*

My Rig:

gigabyte z77-ds3h mobo

i5-3570k cpu

cooler master M2 silent pro 850w PSU

XFX R9 280 DD


So my new R9 280 got here today so I removed my old GPU (AMD 7770) and installed the new one in the case, made sure power was tight and tried to start it but it wont P.O.S.T. Took the new one out, plugged into on-board and it fired right up, removed old drivers and downloaded new ones, no luck. Reinstalled windows, no luck. Old card works fine on new windows install.

is my card DOA?

and tips or idea's are appreciated

Sounds DOA to me. I don't put too too much effort into trying to get a product like that to work, it isn't worth my time. I would expect it to work properly out of the box. If I were you, I'd send it back tomorrow. 

Wait to see what others may have to suggest first, however.

Update: Problem fixed

forgot to update my uefi, got it sorted out and runs like a dream

Hey! I'm in the same boat as you were. Could you please tell me how your GPU worked after the bios update?

Update:  I went ahead and tried another gpu and it worked. So it looked like I had a bummed card.