Install Ubuntu Grub Black Screen

So looks like this question gets asked a lot, but it is after ubuntu is installed it seems. I haven't messed with a Linux distro in awhile, but I am sure I am doing it right. I have tried installing many distro's before and never ran into a problem like this. Also I am trying to dual boot with windows 7 which the boot is in GPT. Changed it to that, because looking around it seemed to be UEFI problem or something, but didn't make a difference.

I am trying to install ubuntu 14.10, but when I get to the grub menu that says, "Try ubuntu, install ubuntu, oem install" I click "install ubuntu" and my screen is black and computer restart after a bit.

I have pushed "e" at the menu and changed "quiet splash" to "nomodeset" and that does nothing. I assume I have to see something on my screen for that to work anyway. I've even tried installing 14.04 and same problem.

Here are the specs of my computer if that helps any:

CPU: AMD 8350 Mobo: Asus M5A99X Evo GPU: AMD 6870

Thanks hope this is an easy fix!

This was a question that I put on ask ubuntu, they didn't help me , so hopefully someone can point me in the right direction. Never had this problem until trying to install 14.10. I did have windows 8 on my ssd, but removed for 7 and ubuntu. Thanks

That might of caused the problem, but this seems a little too complicated for my skill level so I have no knowledge on how to fix it so here is a link hope it helps.

Thanks, I believe I have tried everything listed on that page and that is the same link Ubuntu gave me. Wish it would of work.

Also I guess I forgot to put in my message that I did have 7 in MBR and still had same problem.

I guess I could try other distros, but I am one of the few it seems that likes unity. Lol

I get this every once in a while, usually it's a fluke though. Here's what I suggest:

Redownload the .iso

Open Disk Management
Open command prompt as administrator
Windows Key + R


(pin it to task bar, right click icon, right click command prompt again, run as admin)

sel disk 3

The disk number you get from Disk Management


WARNING it erases everything on it.

Now in Disk Management just create a new FAT32 partition and then use Win32 Disk Imager to make the USB flash drive. When selecting the image file with it, you have to select All Files or . from the drop down instead of .img or you'll never find it.

Then try rebooting again.

Also, make sure Fast Boot is disabled in BIOS, and try removing the USB and trying it in another port.

i am thinking bad media as it isnt even getting anywhere near anything hardware related

Alright so I was being slightly dumb...I am still confused a little about why some things aren't working, but Ubuntu is now on my computer. I had to run it in nonuefi mode and then when getting to Ubuntu's pink screen hit f6 and checked "nomodeset" and the other 2 options the link says do. I figured since Windows 7 is now GPT that Ubuntu had to as well or boot it with UEFI? I put both on my SSD, but Windows 7 is in GPT and I am assuming that Ubuntu is MBR or what it tells me "Legacy."

So with my OSs setup that way they are both not under grub and I can not choose which to boot to. I have to go into my Bios and change which disk I want. I have UEFI windows boot (boots to Windows 7) or just the HDD name (boots Ubuntu). Not sure what to do, so guess I'll look at the link again and make sure to read it all instead of skimming to what looks to be my problem.

Also I am currently trying to use the boot-repair, because I remember reading somewhere about converting grub from legacy to uefi or something like that. So I'll see if that works. (Yep doesn't work, in UEFI it goes to the boot screen like UEFI is supposed to, but then I say to run it goes to black screen and then restarts my computer. If I run it in nonUEFI I just go straight to Ubuntu.)

Don't know what Ubuntu has done since 13.10, but it has never been that difficult for me to get it running. I've dual booted with windows 7 and windows 8, but trying to install 14.04 or 14.10 has been nothing, but a pain. lol

So hopefully what I have written makes sense and if you guys still know what to do, the help would be appreciated. Thanks!

I'm 99% sure that the issue lies somewhere in the BIOS settings, but if there are no settings like mine has, then we'll have to do without.

So when you're booting/installing UEFI USB, in my experience, weird things will happen. I tried to install Windows 8, Windows 8.1, Windows 10, and all of them would just keep giving me this error at the install. In the end what I had to do is disconnect all the hard drives I had and then it ran just fine.

If you can install Ubuntu on a drive by itself, you can reconnect the Windows drive, boot into Ubuntu, and run

sudo update-grub

And if Ubuntu can see it, it will add it to the grub boot. If it can't see it, there's either something wrong with Ubuntu, or some weird setting in the BIOS. (Again, in my experience, and I can't remember which of the 10-20 things I tried that resolved the issue)

As far as it installing and then grub not being able to find it, what probably happened is at the end of the install it ran grub-install /dev/sda and then update-grub but failed for whatever reason. Another thing you can try is the following:

  1. Pick "Try Ubuntu without installing". You can still install from inside Ubuntu, there's going to be a shortcut either on the left side or on the desktop.
  2. Try unchecking "download updates while installing" and the other codecs one. There's a user here on Tek Syndicate that had that issue and this solved it.
  3. Only connect one HDD and install on it. (the next part isn't for you as you have Windows 7) If you're installing onto the same HDD as Windows 8 or above, make sure fast boot is turned off. It's in the power button settings.

Windows 7 and Ubuntu are both on the same SSD. You saying I should try to install on a separate HDD? Also my mobo does not have options for fastboot and secure boot. My mobo was out before then, revision 2 of my mobo does have those option.

I may end up just wiping my drives and just starting over. Put windows 7 back at MBR and see what happens. Only thing is that I still had this problem then, but it might of just been a graphic issue =(

Best solution would be one drive per OS, but I've done exactly what you're doing before, so it certainly is possible.

If you aren't doing UEFI, then you can't do GPT in Windows, which means you can't boot to the USB or DVD you have in UEFI to install Ubuntu without breaking something.