I'm trying to learn how to speed up my boot-times

I’m pretty new to linux in general and chose Fedora KDE, and love it so far. It feels like my computer is booting slower than it did on windows though. After some googling I ran a couple commands, and I think I found a problem with this command

$ systemd-analyze blame

it returned a bunch of lines, I’d really appreciate if you guys could help me figure out what’s wrong so I can fix it. Looking at these I see my second drive and I’m not sure why because I did a clean install on my new M.2 SSD. I think my computer might have grub installed on the second drive because it’s still able to see my arch linux installation on my second drive and it gives me the option to boot either of them when I turn on my computer.

1min 6.892s sys-module-fuse.device
1min 6.859s dev-disk-by\x2did-wwn\x2d0x5002538e40c2f1f9.device
1min 6.859s dev-disk-by\x2dpath-pci\x2d0000:02:00.1\x2data\x2d1.0.device
1min 6.859s sys-devices-pci0000:00-0000:00:01.2-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda.device
1min 6.859s dev-disk-by\x2dpath-pci\x2d0000:02:00.1\x2data\x2d1.device
1min 6.859s dev-disk-by\x2ddiskseq-1.device
1min 6.859s dev-disk-by\x2did-ata\x2dSamsung_SSD_860_EVO_1TB_S3Z8NB0M145586T.device
1min 6.859s dev-sda.device
1min 6.858s dev-disk-by\x2did-wwn\x2d0x5002538e40c2f1f9\x2dpart1.device
1min 6.858s dev-disk-by\x2ddiskseq-1\x2dpart1.device
1min 6.858s dev-disk-by\x2dpath-pci\x2d0000:02:00.1\x2data\x2d1\x2dpart1.device
1min 6.858s sys-devices-pci0000:00-0000:00:01.2-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda1.devi>
1min 6.858s dev-disk-by\x2did-ata\x2dSamsung_SSD_860_EVO_1TB_S3Z8NB0M145586T\x2dpart1.device
1min 6.858s dev-sda1.device
1min 6.858s dev-disk-by\x2dpath-pci\x2d0000:02:00.1\x2data\x2d1.0\x2dpart1.device
1min 6.858s dev-disk-by\x2dpartuuid-572f6045\x2d808a\x2d394f\x2d8db8\x2d852b1e60fcf6.device
1min 6.834s dev-ttyS16.device
1min 6.834s sys-devices-platform-serial8250-tty-ttyS16.device
1min 6.833s sys-devices-platform-serial8250-tty-ttyS17.device
1min 6.833s dev-ttyS17.device
1min 6.832s sys-devices-platform-serial8250-tty-ttyS21.device
1min 6.832s dev-ttyS21.device
1min 6.831s dev-ttyS22.device
1min 6.831s sys-devices-platform-serial8250-tty-ttyS22.device
1min 6.831s sys-devices-platform-serial8250-tty-ttyS18.device
1min 6.831s dev-ttyS18.device
1min 6.830s dev-ttyS2.device
1min 6.830s sys-devices-platform-serial8250-tty-ttyS2.device

It is really hard to say. What is the bootloader for Fedora? Are you using an EFI aware bootloader? I run Debian and ArchLinux on an AMD FX-6300 system with crucial SATA SSDs. My system boots in 10 seconds or less from post to login.

Maybe your initcpio/initrd/initramfs is large and has all modules enabled. All of that has to get loaded at boot to then boot to the kernel.

I don’t RedHat anymore (20 years) so, besides servers, I have no real input for Desktop stuff.

Remember that Windows isnt really “rebooting” most of the time, especially during its start menu shutdown option.

Also you should opt for suspend, instead of the usual shutdown for a faster “boot” experience. Most updates wont require a reboot, unless you are on Silverblue (or Kinoite).

As for modifying anything during boot, best wait for other replies because I am unsure if it is helpful.

i just ran systemd-analyze blame and all my results came back with 2 seconds or less most being .5 or less.
so if your getting a return in the minutes then maybe check the drives integrity…
there should be a drive test in bios

grub will or should be on both distros.

once installed, you just go into bios and select the drive with the distro you want to boot from and grub will load off that disk.
with the only difference to booting off the other install being whats in the grub boot list.
1 will have boot arch, the other fedora. as first boot option.


I figured it out, Fedora was actually hiding the errors in the boot log. I was getting USB Device error -110. Apparently a device I had was drawing too much power from my machine and fedora stalled trying to do … something? I unplugged the usb roku device and now it boots in about 3 seconds after posting, yay nvme!


Thanks for following up. It sounds like Fedora was trying to reset the bus and then eventually gave up.

I was just going to comment about USB devices. I usually have a bunch of cold store HDD’s plugged in and they can stall if i don’t have my Key drive ready. Also, systemd-boot is fast as hell.

I use it with ArchLinux. I use grub with Debian, since it is my main environment.