I'm not able to run devcontainers on my linux machine

I have been having issue with running remote containers for VS Code on my Linux PC. The .devcontainer.json I use worked fine on my mac(died couple of days back). I have described all the issues on the microsoft/vscode-remote-release git page.

Here’s the link to the issue/bug I created https://github.com/microsoft/vscode-remote-release/issues/4263


I try to open my current folder in a container with my dev environment and I keep getting this error:

   [PID 174307] [876 ms] Start: Downloading VS Code Server
   [2021-01-04T18:33:21.788Z] [PID 174307] [2589 ms] Error: connect ECONNREFUSED
	at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1134:16)

I tried uninstalling and re-installing vscode and docker but no luck there either. I tried running vscode without extensions but that didn’t help either.

I am running Arch Linux with LTS Kernel 5.4.86-1-lts

My system specification are:

Operating System: Arch Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.4.86-1-lts
OS Type: 64-bit
Processors: 32 × AMD Ryzen 9 3950X 16-Core Processor
Memory: 62.8 GiB of RAM
Graphics Processor: Radeon RX 580 Series

Does anyone else have this issue, or I’m the only one? :pleading_face:

I’m stupid!!

It looks like it was a DNS issue. I was using dnscrpt-proxy in my USG pro and it was resolving that and even the vscode download URLs from Microsoft’s website to Don’t know why. I switched back to dnsmasq, flushed the cache and it started working.

1 Like