I'm getting desperate over GPU driver

Hello guys,
First of all, sorry if I got section wrong, first time posting here.

For the past a week or two, I’ve been trying to move fully on Linux from Windows. So far, I’m able to do all my work on Linux and I got no problem there. Unfortunately, because I log every once in a while into a couple of games, I still use Windows partition. And I hate doing that.

By the books, if you want to play some games, you have to install appropriate driver. On my freshly installed Manjaro I did just that. Got into System Settings -> Hardware Configuration -> And checked Auto Install Proprietary Driver. After successful installation and reboot I assumed everything should work. However, I still got some really bad performance in games. I know Linux is not (yet) like Windows, performance wise, but it’s up there. After some digging around I’ve come to conclusion that drivers are not installed. How did I figure that out? Well, after executing screenfetch command, under GPU was just Unknown. Weird. Quick search resulted that I have NVIDIA X Server settings installed but after running it, I got error that no driver is installed. After running inxi -G command I got following output:

Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
v: kernel
Device-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A
Display: x11 1.20.5 driver: intel
resolution: 1920x1080~60Hz, 1440x900~60Hz
OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.1.1

For me it looks like my OS knows about my hardware, just doesn’t have driver for it. After running mhwd -li command, I got following output:
Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE
       video-linux            2018.05.04                true            PCI

video-hybrid-intel-nvidia-390xx-bumblebee 2018.08.09 false PCI
network-r8168 2016.04.20 true PCI

Where I did wrong? And what the hell is happening here? Now, keep in mind that I have integrated GPU as well as dedicated one (GT 740m). Is there any hope for me and ever ditching out Windows partition? I’ve tried to explain everything as detailed as possible. Hope you guys can help me out. Thanks.

I’m guessing you are on a laptop? So rather than uninstall the integrated graphics, you probably want something like bumblebee or Optimus?
They are apps that should switch graphics in Linux ok laptops.
I would recommend googling them with arch and manjaro.
Also check out the arch wiki?

Oh, and if you don’t need to worry about battery life, you might check out Prime?
The instructions say when not to reboot, which is important at a key stage, and it has instructions near the bottom to render on the discrete card, then pass the image to the integrated, in case there is issues that way?

I have installed Bumblebee driver. Under installed PCI configs is, just probably didn’t format it correctly

I’m not going to have a dig at Manjaro, heck I run it on my laptop but, If you are finding this all to be a bit tricky have a look at Pop!. Pop!_os is a distro made by System 76. They needed a disto that was easier for their laptop customers to use. It’s based on Ubuntu but has all of the rough edges smoothed. There is a version with the nvidia drivers preconfigered for laptops. By all reports it should work out of the box on a laptop with nvida graphics.

You are going to be able to make it work with Manjaro, it’s just that you are going to have to do the leg work.

1 Like

Before Manjaro I did use Pop!_OS with same result unfortunately. I managed to get drivers going, and programs still used integrated GPU. After digging around with nvidia prime (I think its called something like that) I ended up braking my system and couldn’t boot into it anymore. Thanks for response, anyway.

Moved to Linux section and added help desk tag.


Hi, I don’t have much experience with laptops running dual GPU’s. (So no warranty that this will work)

As a precautionary step unplug your external monitor until the installation is complete and you have restarted.
In the terminal enter the following:

sudo rm -rfv /etc/X11/xorg.conf /etc/X11/xorg.conf.d
sudo pacman -Rsn libvdpau xf86-video-nouveau
sudo pacman -S bumblebee nvidia nvidia-settings nvidia-utils mesa lib32-virtualgl lib32-nvidia-utils
sudo gpasswd -a user bumblebee <-- replace user with your username
sudo systemctl enable bumblebeed.service

restart the computer once all the commands are completed.

If my understanding is correct, as long as you are plugged into power bumblebee drivers should automatically render on the nvidia gpu.
(this of course can be configured and changed, but lets see if we can get you up and running)
Here is more info below:

Edit: removed opencl-nvidia from install list, might not be needed because of mesa, might cause a conflict.