iGPU Passthrough failing, FLR Waiting on iGPU/Reset Bug

I have finally decided to get some help with this, I am trying to pass through my i9 10900’s integrated GPU (UHD 630) using my asrock B560m Pro 4. I have gotten the iGPU passthrough to work on my i5 8250u laptop and it works great on there, but on my main PC Not so much. My first attempt at doing this was in proxmox, I followed my usual procedure to pass through the iGPU (see below) after that I tried to start a linux vm (it works better than windows because of the driver already being integrated) upon doing this the entire system froze up to the point where the reset button wouldn’t even work. I rebooted and checked dmesg and I saw an error saying FLR Waiting (insert time here) I kept on trying with different configurations (q35/i440fx x-igd ovmf) and all that stuff and none of it worked. I eventually decided to try and apply a kernel patch, and I applied a quirk that made it so that the iGPU have “no flr” that seemed to make the vms start up now but now I had a code 43 error in windows and linux reported that the card was “wedged”. Meanwhile the monitor was either sitting on a black screen or it went to no signal. But one time when I was doing the windows install in ovmf mode, I saw a bunch of colored stripes on the monitor but they went away after I windows reached the OOBE (setup).

How I passed the iGPU through

First I edited /etc/default/grub (appended kernel parameters) to disable the display and bind the card to vfio the final kernel line ended up being

GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on iommu=pt nofb nomodeset video=vesafb:off,efifb:off,vfio.pci.ids=8086:9bc5

Then I blacklisted the modules in /etc/modprobe.d/pve-blacklist.conf

'sudo echo “i915” > /etc/modprobe.d/pve-blacklist.conf`

Then I added vfio modules to /etc/modules/
cat /etc/modules

vfio
vfio_iommu_type1
vfio_pci
vfio_virqfd

Then I added the ignore msrs flag
echo “options kvm ignore_msrs=1” > /etc/modprobe.d/kvm.conf

then I rebooted and the FLR issue happened

Kernel Patch:Attached used with kernel 5.12.8 final kernel files here kernel-and-rom the patch only works with uhd 630 cards with the 9bc5 device id.

I also tried with vbios_gvt_uefi this romfile and Release V0.2.1 · patmagauran/i915ovmfPkg · GitHub both didn’t work but the second one caused a system lockup similar to the FLR error even with the kernel patch

GVT-g works flawlessly

Thanks in advance

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.