I think i bricked my Galaxy S3

So my parents recently got new phones so I got their old ones. Which was awesome because I am coming from a HTC Droid Incredible 2. Naturaly the first thing I thought I should do was Root it and install a coustom OS. I had no idea whatso ever on how to do it so I read a bunch of guides and they all said the same thing. So I rooted my phone and it worked. So then I went on to unlock the boot loader. I used a software called ez-unlock 1.2 and then my phone wont turn on any more or charge. Except when I take out the battery and plug it in then the charging light will turn on. Is there any way to fix?


PS I am running Verizon

Attempting to unlock the bootloader for the S3 after updating it to Android 4.3 is known to cause a hard brick, and major carriers have been pushing it out. Depending on your carrier, updating to 4.3 also activates a firmware warranty system that locks you out of unlocking the bootloader even if you downgrade, but that's irrelevant if you already attempted to unlock the bootloader with an updated system, which will cause the hard brick.

You're going to need to try and burn a custom debrick image for your carrier, for the android version that you bricked, to an sd card, and if the phone can still try and boot from the card, you may be able to save it.

I didn't update Android. I was trying to install Android Revolution HD. And how would I use a debrick image if the phone wont even boot?

You didn't update it, but what version was it running when your parents gave it to you? What Service Provider is it on?

There are reports of fixing a hard brick, even when the phone is unresponsive.

I GOT IT TO BOOT. I did a little bit more resarch on how to get it to work using an unbricking file on my sd card and it worked! So now I need to restore the boot loader right? how would i do that? and my sd card shows only 60mb. and it wont boot unless i have the sd card in

Then the next step is to attempt to revert the phone back to a working OS. Once again, it really depends on who the carrier is, and if you can obtain the corresponding image and provision the phone correctly so the OS is running on the phones flash memory.

I can boot onto the phone and it works. but I have to have the sd card in and the sd card has no space. can you help me step by step? i dont want to break it again...

I believe if you have an image mounted on it, it reserves all of the available space. Correct me if I'm wrong, but I think you need to format the SD card. I haven't used an Android in two years so I am no longer familiar with rooting and ROMs.


I do have an image mounted on it. It is what makes the phone work. I need to figure out on how to get it to work without it