[I made it worse, pls help] Some sort of screen flickering

I don’t know what to call this so I will just call it flickering. I think there is a disconnect with the Nvidia 520 drivers and the refresh rate on my Gigabyte M32U (4k-144hz)…

Using Ubuntu MATE and the Proprietary driver 520… Refresh rate of 144 doesn’t appear in the driver settings. Have items like vsync on.

For some reason the driver is identifying the signal as “TMDS” as opposed to HDMI

Appreciate any ideas.

WWED

xorg.conf below:


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "GBT Gigabyte M32U"
    HorizSync       30.0 - 255.0
    VertRefresh     48.0 - 144.0
    Option         "HDMI"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce RTX 3080 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "HDMI-0: 3840x2160_144 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-2: nvidia-auto-select +3840+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

get some good cables? its probably the cables.

Well W, what I do know is I f’ed around too much and can’t boot property. Is there a way to remove nvidia drivers from a live cd/usb?

Now I just get locked up during boot

EDIT:

I apologize, I don’t know what happened. I was able to bypass getting locked up at boot by using my iGPU as the primary graphics device. I could no remove nvidia packages due to an issue relating to nvidia modules (kernel?). for whatever reason, I updated my system of which included a kernel update and I was able to roll back to the working nvidia 510 driver…which now reflects 144hz… what the hell am I doing…I need a better understanding of these things.

@wendell

Not the cables… just some weird behavior with drivers past the 510 version

Technically everything in a modern PC is TMDS.
I hope that’s something as simple as drivers. I’d be worried it’s hardware level artifacting. Had a problem with that recently, made recordings, notice problem, watched recording and notice even more instances similar to that.
Is that Gimp? I’d probably call it texture flicker.

+1
If it was refresh rate related it’d be the whole screen not just something localized like that

Might be memory or core going

Like the card is going bad? It’s only weird with drivers after 510

Yea gimp, also does it in desktop, every window etc. possibly would the window manager come into play here?

If your lucky. Emphasis on “if” and “lucky”.

1 Like

Is it a card that allows clock adjustments? Drop them to the floor and see if it still happens. If that fixes it, the GPU is going out. If that doesn’t fix it, might still be going out.

Did you double check by re-installing the older drivers?

It was v sync related in the newer driver. Turns out

Pretty screwed though. There is a bug in the older driver that caused excessive power draw at idle, 80-100W for me and the newer one, well it’s not working well with my M32U.
Can’t get refresh rates above 60hz pretty pissed.