I just got ASRock C236 WSI for a pfsense box

So yeah I got the new ASRock C236 WSI m-ITX for a Pfsense box and I got a Intel Xeon E3-1220 V5, and I didn't check for onboard GPU and I assumed it's there, any way Now I'm trying to make the board boot without checking for Video card, But each time I remove the External GPU or disable the video option in the bios I get the 5 beeps for no GPU detected error.

any way around that? I mean i don't need video and I don't want to get a cheap gpu because I want to use that Pci-e for NIC's

I see the gpu outputs in the pics.

I just built my first pfSense box two days ago. I'm super pleased. It kicks butt.
However, I used and old gaming rig and I still need something replace the big gaming gpu. lol. There's no integrated gpu on the mobo.

I'm using this for my network card and so-far (albiet only a few days) it's had no issues.

Update the bio and see if that helps, otherwise you might be stuck selling that Xeon and buying a skew that comes with integrated graphics.

You need to have a gpu installed.
Because the Xeon 1220-V5 does not have intergrated graphics.
Thats why it doesnt boot.

  • Xeon E3-1225-V5 4 cores 4 threads.
  • Xeon E3-1245-V5 4 cores 8 threads 3.5Ghz base 3.9GHz boost
  • Xeon E3-1275-V5 4 cores 8 threads 3.6Ghz base 4.0GHz boost

These Xeons have an igpu.

Might just be cheaper / less hassle to get a cheap gpu card to leave in the system

He only has one expansion slot so a GPU would mean he couldn't put in the networking card that he wanted. A PfSense box really is a networking box that doesn't need a gpu so him requiring a gpu over the networking functionality would be rather dull.

Oh, didnt see that detail.

How about a pcie splitter ribbon?

your mobo/bios must support bifurcation ,check with asrock support if it does. You might try using serial port also .

pfSense can be run without VGA, might be a problem to get it to boot though. You want the serial console image for installation.

I am having a video issue as well. I purchased the Xeon E3-1275 V5 with integrated graphics for a FreeNAS box, and I have no video at all. I can't even get into BIOS. I also tried a discrete card and still no luck. I swapped out different ports, monitors, unplugged all the hard drives except the the boot drive and still no luck. I don't receive any beep errors either. Any suggestions?

what about a cheapo USB Video Card? Maybe the BIOS will be ok with that?
Something like that http://geizhals.de/secomp-usb-3-0-auf-vga-adapter-12-99-1037-a1324775.html?hloc=at&hloc=de

You seem to be misinformed and don't understand the problem correctly. The problem is not that there is no VGA output but neither the CPU nor the mainboard has an integrated GPU. Therefore graphics cannot be processed. The link you've posted is a USB-VGA-adapter, not a video or graphics card.

i understand this. But this in't a adapter, this is a (very crappy) videocard! And with luck, the bios could potentionally recognize it like a "normal" gpu.

Can you read?! It is an ordinary USB-to-VGA-adapter: http://geizhals.de/secomp-usb-3-0-auf-vga-adapter-12-99-1037-a1324775.html?hloc=at&hloc=de

What on earth makes you think it might be more than that?
There is no GPU in it.

Ok i read a bit further.
Before Displaylink 4.3 the CPU emulated an indipendend graphics card and send the comprimated data to the usb device.
From 4.3 till now it emulates another port at the graphicscard.
So with older hardware it may be possible to use it without a graphicscard, when you get your computer into booting. Due to the fact that even then the computation is done on the cpu by the driver itself it will only work after loading the driver and this will not be done by the computer when in bios. So it wont work.

My thoughts are incompatible RAM (not likely) or mobo arrived with defects. The RAM I'm using is crucial's ECC DDR4 which is not on the compatibility list for the mobo, but crucial kits usually work with most builds even if not officially reported as such. What I find interesting is that when I plug in the discrete card, then fan doesn't come on at all. In my experience a card fan will turn on at startup even if it ends up not needing the fan.